VirtualBox

Ticket #9661 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

VM aborts with segfault on host

Reported by: nhajek Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Windows 7 & Windows Vista guests, both 64 bit abort with a segfault in the host message log at the time of the abort. Happens randomly, usually after the guest has been on for several hours and the guest will not run more than 24 hours without this occurring. Host is openSUSE 11.4, 64 bit with virtualbox 4.1.2. This problem started after installing 4.1.2, previous virtualbox version 4.0.10 worked fine. Below are the segfaults from the host log.

Sep 15 18:27:06 mts4-pc kernel: [3704754.682347] VirtualBox[14615]: segfault at 7ffcb815ec00 ip 00007ffcdb9ba8e2 sp 00007fff34a57e28 error 4 in libc-2.11.2.so[7ffcdb93b000+156000]

Sep 16 19:19:02 mts4-pc kernel: [84076.544182] VirtualBox[26708]: segfault at 0 ip (null) sp 00007f68f027cbb8 error 14 in VirtualBox[400000+6000]

Sep 17 16:38:17 mts4-pc kernel: [ 8995.424716] VirtualBox[9360]: segfault at 8 ip 00007f2cc69ba9f8 sp 00007f2cb0db69b0 error 6 in VirtualBox.so[7f2cc670f000+557000]

Sep 18 15:51:54 mts4-pc kernel: [92611.717137] VirtualBox[17861]: segfault at 8 ip 00007f653e2229f8 sp 00007f65276fc9b0 error 6 in VirtualBox.so[7f653df77000+557000]

Sep 20 17:31:49 mts4-pc kernel: [271407.058771] VirtualBox[30481]: segfault at 8 ip 00007fd92b05b9f8 sp 00007fd9146079b0 error 6 in VirtualBox.so[7fd92adb0000+557000]

Sep 20 20:57:40 mts4-pc kernel: [283757.429190] VirtualBox[17336]: segfault at 8 ip 00007f0753b289f8 sp 00007f073dee19b0 error 6 in VirtualBox.so[7f075387d000+557000]

Sep 20 21:00:39 mts4-pc kernel: [283937.139608] VirtualBox[3328]: segfault at 8 ip 00007f13682669f8 sp 00007f1351f809b0 error 6 in VirtualBox.so[7f1367fbb000+557000]

Sep 23 20:06:36 mts4-pc kernel: [539893.613139] VirtualBox[24339]: segfault at 8 ip 00007fb9a12c89f8 sp 00007fb9906b79b0 error 6 in VirtualBox.so[7fb9a101d000+557000]

Sep 23 20:10:35 mts4-pc kernel: [540132.613242] VirtualBox[24477]: segfault at 8 ip 00007fcdbf1c69f8 sp 00007fcda8eeb9b0 error 6 in VirtualBox.so[7fcdbef1b000+557000]

Sep 24 16:41:54 mts4-pc kernel: [614012.169173] VirtualBox[31550]: segfault at 8 ip 00007fdaba6b19f8 sp 00007fdaa8b239b0 error 6 in VirtualBox.so[7fdaba406000+557000]

Sep 25 08:32:00 mts4-pc kernel: [671017.555266] VirtualBox[29337]: segfault at 8 ip 00007ff8b02d99f8 sp 00007ff89a6ac9b0 error 6 in VirtualBox.so[7ff8b002e000+557000]

Attachments

virtualbox_logs.tar.gz Download (39.5 KB) - added by nhajek 3 years ago.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.4. In that case please attach a VBox.log file of a VM session when VBox crashed.

comment:2 follow-up: ↓ 3 Changed 3 years ago by kerlerm

Seems to be connected to this bug: https://www.virtualbox.org/ticket/9644

comment:3 in reply to: ↑ 2 Changed 3 years ago by kerlerm

Replying to kerlerm:

Seems to be connected to this bug: https://www.virtualbox.org/ticket/9644

Vbox.log is available there.

Changed 3 years ago by nhajek

comment:4 Changed 3 years ago by nhajek

  • Status changed from closed to reopened
  • Resolution fixed deleted

The problem still exists the message in the host log is below

Oct 5 18:19:10 mts4-pc kernel: [1570248.074832] VirtualBox[19353]: segfault at 8 ip 00007f6afb957d28 sp 00007f6ae5cfc9b0 error 6 in VirtualBox.so[7f6afb6ab000+55c000]

I've attached the vb logs. Additional information, AMD Phenom II X6 1055T processor, 16gb ram

comment:5 Changed 3 years ago by nhajek

Update - The segfault occurred once, noted above, since upgrading to 4.1.4 but has not reoccurred since that single instance.

comment:6 Changed 2 years ago by nhajek

In the last update, I noted that the segfault had only occurred once since upgrading to 4.1.4. Two days after that it crashed again and continues to segfault about every day. I upgraded to 4.1.6 and the problem continues, the error logged in Linux is now segfault at 8 ip 00007f106385e9e8 sp 00007f104dac89b0 error 6 in VirtualBox.so[7f10635b1000+55d000]

Is there anything I can do to help track down this problem?

comment:7 Changed 2 years ago by frank

nhajek, we can only debug this issue if you can provide a core dump. If you, please contact me via private E-mail at frank _dot_ mehnert _at_ oracle _dot_ com.

comment:8 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the core dump! Actually this is a duplicate of #9194. Please continue the discussion there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use