VirtualBox

Ticket #9636 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Windows XP command prompt crash with guest additions -> Fixed in SVN.

Reported by: bob3248 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.2 Keywords: command prompt
Cc: Guest type: Windows
Host type: Windows

Description

Host: Windows 7 SP1 64bit VirtualBox 4.1.2 Guest: Windows XP Pro SP3 32bit, clean install, default VirtualBox options except 512MB RAM, using VT-x acceleration

If I open a command prompt, it opens in a window and works normally. I can press Alt-Enter to change the command prompt window to full screen and that also works normally. However, if I press Alt-Enter again to return the command prompt to a window the virtual machine hangs with a black screen. It then either remains frozen so I need to power off the virtual machine or reboots after a few seconds.

This problem only happens if the guest additions are installed.

The same issue is present under Windows NT 4.0, Windows 2000, Windows Server 2003 R2 32bit, and Windows 7 32bit. 64bit Windows systems are not affected because they cannot display a full screen command prompt.

Change History

comment:1 Changed 3 years ago by Hans83VT

I can confirm this is also a problem under VirtualBox 4.1.2 (r73507). I am using Ubuntu 10.04 as the host operating system (all updates applied) and Windows XP Pro SP3 32-bit as the guest OS. Guest additions are installed.

comment:2 Changed 3 years ago by leonid

  • Summary changed from Windows XP command prompt crash with guest additions to Windows XP command prompt crash with guest additions -> Fixed in SVN.

Thanks for your information, fixed in SVN.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 4.1.4, please also update your Guest Additions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use