VirtualBox

Ticket #9570 (reopened defect)

Opened 3 years ago

Last modified 3 months ago

MacOSX Menubar appearing in Fullscreen Client

Reported by: srd Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.2 Keywords: menu bar, fullscreen
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by michael) (diff)

After the Host Screen is locked with the screensaver or the host goes to sleep, and is subsequently woken up, the MacOSX Menubar for VirtualBox appears in a full screen client, when the cursor moves to the very top of the screen.

A workaround to keep the menubar from appearing again is to switch the guest out of fullscreen, minimize the guest to the dock, have the guest window come back up and switch back to fullscreen. Then the menubar does not reappear, until the next time the host display is locked.

Host is MacOS X SnowLeopard, Guest is Ubuntu 11.04. This also happened with VirtualBox 4.0.x.

Change History

comment:1 Changed 3 years ago by hder

It should be noted that some users prefer the ability to see (or autohide/autoshow) the Mac OS/X MenuBar when the guest is in full-screen mode.

There is an option under 'VirtualBox->Preferences':

"Auto show dock and menubar in full screen"

comment:2 Changed 3 years ago by srd

Yes, I am aware of this option and it was the first thing I disabled. So the menu bar is being shown after a host screen lock _despite_ me telling VirtualBox that I don't want to see it - so I would consider this a bug where the behavior runs contrary to the specified options.

comment:3 Changed 3 years ago by oatmeal357

I can confirm this issue on OSX 10.7.4 with virtualbox 4.1.20. In addition to this there is a further issue where after switching workspaces and coming back to the fullscreen vm, the menubar will appear when placing the mouse cursor on the upper portion of the screen.

I have the "Auto show dock and menubar in full screen" option unchecked.

Last edited 3 years ago by oatmeal357 (previous) (diff)

comment:4 Changed 2 years ago by zeagle

I have witnessed this problem as well on OSX 10.7.4 virtualbox 4.1.20. The menu bar will appear despite changing the preference. I even modified the info.plist, I changed the value of LSUIPresentationMode which normally will hide the menu bar in all cases, however it did not work for VB.

comment:5 Changed 2 years ago by porg

@developers: Wow! Reported 14 months ago, and still unfixed! :-(

@srd: Thanks for your workaround! You made my day!

I wanted to use VirtualBox within a usability test:

I run a prototype software in the guest OS Windows XP on the host Mac OS X 10.6.8 within VirtualBox 4.1.23 r80870, displayed fullscreen on the Mac, and on the Mac side running the screen recording software Silverback 2.5.7 (521). Works all amazingly well, except if the user within Windows OS moves to the top screen area, the Mac menu bar gets displayed, regardless of the setting > General > Auto show Dock and Menubar in fullscreen, which seems to be ignored.

@srd's workarround works so far as of r80870

Last edited 2 years ago by porg (previous) (diff)

comment:6 Changed 2 years ago by porg

Related bugs:

  • #5636 feature was once introduced, worked back then.
  • #10340 special variation of the problem described here.

comment:7 Changed 2 years ago by michael

  • Description modified (diff)

porg, unfortunately this is due to limited resources which we have to focus on issues which affect paying customers. Before you point it out, I realise that this issue could too in theory, but so could any of the other several thousand open issues, and many of those have more severe consequences. By making our source available we do provide an alternative for users who badly want things fixed that we don't currently have time to look at. I will bring this to the attention of the developer most likely to be able to fix it, but of course I can't make any promises.

comment:8 Changed 2 years ago by porg

@michael Thanks for your explanation and efforts.

comment:9 Changed 12 months ago by JohnW

It is curious why this is still an issue nearly 5 years after it was first brought up. It renders the desktop version of Ubuntu nearly useless because it has the 'infinite' menu bar under unity that directly conflicts with the OS menu bar. The end user has to be very careful not to invoke it and it causes a sense of anxiety as the mouse draws near the top of the screen. Please take this issue more seriously.

comment:10 Changed 11 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VBox 4.3.10 finally introduced the native full screen mode for OSX 10.8 and 10.9.

comment:11 Changed 11 months ago by DC

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm running vbox 4.3.10 (r93012) on OSX (10.9.2), with an xubuntu guest and this bug isn't fixed.

It doesn't matter whether I have ticked the 'Dock and Menubar [] Autoshow in Fullscreen' button or not, at the top of the screen I get the Mac menubar, at the bottom the Dock shows up.

I'm going to have to revert to an old version of vbox again.

comment:12 Changed 3 months ago by Maestro

It is possible to disable the menu bar in fullscreen by forcing VirtualBoxVM.app to run as an agent app. This has some side effects, but is a decent temporary fix. Line to add to Info.plist: <key>LSUIElement</key><string>1</string>

See my comment here for more info:  https://forums.virtualbox.org/viewtopic.php?f=8&t=21676&p=305585#p305585

comment:13 Changed 3 months ago by Maestro

It is possible to disable the menu bar in fullscreen by forcing VirtualBoxVM.app to run as an agent app. This has some side effects, but is a decent temporary fix. Line to add to Info.plist: <key>LSUIElement</key><string>1</string>

See my comment here for more info:  https://forums.virtualbox.org/viewtopic.php?f=8&t=21676&p=305585#p305585

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use