VirtualBox

Ticket #9531 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Already-running guest crashes on attempt to start it again 4.1.2

Reported by: appyface Owned by:
Priority: minor Component: other
Version: VirtualBox 4.1.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Using 4.1.2 on host Win7 Pro SP1 64-bit with guest XP Pro SP3 32-bit.

I use Windows Task Scheduler to ensure some VMs are running during certain periods. The task scheduler issues a script containing these commands:

VBoxManage snapshot "%vmname%" take "%yy%%mm%%dd%-%hh%%min%%ss% autosnap" --description "%yy%%mm%%dd%-%hh%%min%%ss% autosnap"
VBoxManage startvm "%vmname%"

(date/time variables are determined earlier in the script)

In previous VBox versions, if these commands were issued against a running guest, both failed and no update or other harm came to the guest.

Now, the guest is crashed and Critical Error Guru Meditation messagebox is shown. The guest not only stops working but must be recovered, as the snapshot information in the XML files becomes corrupted.

Vbox.log from a crash example is attached. Thank you for your time.

--appyface

Attachments

VBox.log Download (277.4 KB) - added by appyface 3 years ago.
VBox.log with example of crash

Change History

Changed 3 years ago by appyface

VBox.log with example of crash

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9255. Please use the --pause parameter when taking the snapshot.

comment:2 Changed 3 years ago by appyface

My apologies for a duplicate, Frank, I did search for this issue but I didn't find that ticket.

I really don't want to pause the running VM -- I have some processes that will abort when the VM is resumed.

Instead, can I get the old behavior in this situation? That is, fail to take the snapshot and not disturb the running guest in any way?

Thank you, --appyface

comment:3 Changed 3 years ago by frank

We will fix this bug but I cannot promise any ETA. Are you sure that the guest is aware of pause/resume? I cannot imagine that, even the guest system time will be adapted slowly by the timesync service of the Guest Additions.

comment:4 Changed 3 years ago by appyface

Thank you for letting me know this situation will be fixed at some point. No worries on the ETA, I understand.

The ability to take snapshots of the running guest is a really nice and useful feature, and one I'm sure I'll make use of. In this specific case, though, I don't want a new snapshot saved if the guest is already running. So I'll see about modifying my scripts to detect the state of the guest first, and avoid the issue altogether.

Thank you again for your help with this.

--appyface

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use