VirtualBox

Ticket #9526 (closed defect: fixed)

Opened 3 years ago

Last modified 19 months ago

VBox crash when reverting to snapshot

Reported by: mduft Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Hi!

I just hit a strange issue: One of my machines got stuck yesterday, and i rebooted it. since it got stuck today again, i thought i might want to try the last snapshot i created (i have approx. 6 on this machine in a non-linear history (one branching point)). so i state-saved the machine (it was running headless), and then reverted to the next upper snapshot through the virtualbox gui.

suddenly the display changed, and the gui said the machine was inaccessible. i clicked refresh but nothing happened. so i tried closing and reopening the gui. now the machine was there again, but all my other (6!) virtual machines wherer suddenly "powered off". i checked, and all ssh sessions where dead, all virtualbox processes where gone (damn!)

are there any logs you'd be interested in?

my suspicion was that the background service crashed, which seems to be proven by this syslog entries:

Aug 30 08:16:08 s01en22 kernel: [930578.212688] VBoxSVC[11676]: segfault at 0 ip 0812ad42 sp b65ff150 error 4 in VBoxSVC[8048000+2b1000]
Aug 30 08:16:37 s01en22 kernel: [930607.228707] device eth0 left promiscuous mode
Aug 30 08:16:37 s01en22 kernel: [930607.448719] vboxnetflt: dropped 199389 out of 5687471 packets

HTH, if i can collect more information, tell me :) BTW. i'm using 4.1.2.

Change History

comment:1 Changed 3 years ago by mduft

on a side note: would it be hard to include more symbol informations in the open source parts of virtualbox binary builds (VBoxSVC is a part of this, right?). all i can see in VBoxSVC is, that it seems to be a static (or stripped) symbol, which may (or may not?) have something to do with XML manipulation....? separate debug information would be even greater :)

comment:2 Changed 3 years ago by frank

We have more such reports but unfortunately we still search a reliable way to reproduce this problem. If you could provide a  core dump this would be very helpful. Please contact me via frank _dot_ mehnert _at_ oracle _dot_ com if you can provide one.

Re providing debug information: This would be perhaps possible because we archive the debug information for debugging purposes (therefore my request for a core dump). But OTOH this requires additional space and we actually prefer if users provide us core dumps because we (the developer team) usually know better where to dig to get the required information to debug a problem.

comment:3 Changed 3 years ago by frank

Please check if your problem is fixed by VBox 4.1.4 as there was an important bugfix which could affect your problem.

comment:4 Changed 2 years ago by mue

I have the same problem under 4.1.4. When I restore an snapshot, all running machines are stopped. I get this in dmesg:

VBoxSVC[26067]: segfault at 0 ip 0000000000513887 sp 00007ff0a2897be0 error 4 in VBoxSVC[400000+23e000]

And this on console:

VBoxSVC became unavailable, exiting.
VBoxHeadless: error: Code NS_ERROR_CALL_FAILED (0x800706BE) - Call to remote object failed (extended info not available)
Context: "COMGETTER(EventSource)(es.asOutParam())" at line 1294 of file VBoxHeadless.cpp

I can not reproduce it directly, but when I do 5 restores, it happens once. One wired thing: the restore was done, but it leaves an unattached harddisk snapshot.

I started my machines again with the commands from here: core dump. I will post/send the dump, when I get it.

comment:5 Changed 2 years ago by shisheynu

Same issue also in the same condition as mue with 4.1.8 Sometimes it works, sometimes not :

VBoxSVC[31229]: segfault at 0 ip 00000000004c349a sp 00007f2f8c1b7bb0 error 4 in VBoxSVC[400000+280000]
...
VBoxSVC[23355]: segfault at 0 ip 00000000004c349a sp 00007fb47b249bb0 error 4 in VBoxSVC[400000+280000]

comment:6 Changed 2 years ago by frank

  • Description modified (diff)

Any chance for a core dump? If so, please upload it to ftp.virtualbox.org/incoming (write-only directory) and drop me an E-mail at frank _dot_ mehnert _at_ oracle _dot_ com.

comment:7 Changed 2 years ago by mue

Well, I tried this:

$ ulimit -c unlimited
$ sudo su
# echo -n 1 > /proc/sys/kernel/core_uses_pid
# echo -n 1 > /proc/sys/fs/suid_dumpable
# exit
$ vboxheadless -s VM_NAME --vrde off &

Now I took an snapshot of VM_NAME and made an reset of VM_NAME. At this point all machines crashed, just like before. But I don't get a core dump file. All I got is an extended info in dmesg: ftp.virtualbox.org/incoming/mue.dmesg.log

comment:8 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.22 / 4.2.0. We fixed a couple of related bugs in the meantime.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use