VirtualBox

Ticket #9496 (closed defect: obsolete)

Opened 3 years ago

Last modified 2 months ago

VB 4.1.2 - ubuntu 11.04 vnc telnet gui vboxheadless segfault error 4 in libc-2.13.so[7f74d1da2000+18a000]

Reported by: burdi01 Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.1.2 Keywords: VB 4.1.2 ubuntu 11.04 vnc telnet gui vboxheadless segfault error 4 libc-2.13.so
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

VB 4.1.2 - Xubuntu 11.04 : Linux riposo 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:02:55 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux When running the GUI in a VNC session (TigerVNC 1.0.90 or RealVNC 4.1.1) starting a VM results in a NS_ERROR_CALL_FAILED (see attached screenshot-01.png This problem was already seen with VB 4.0.12. The then workaround was to telnet-in to the host and start the VM via VBoxHeadless. This succeeded 3 out of 4 times. Alas with VB 4.1.2 starting a VM via VBoxHeadless consistently fails with a segmentation fault (see attached screenshot-02/03.png). Luckily SSHing-in to the host and starting the VM via VBoxHeadless consistently succeeds.

Attachments

Burdi01-00a.tar.gz Download (52.9 KB) - added by burdi01 3 years ago.
Settings and logs
Screenshot-01.gif Download (233.4 KB) - added by burdi01 3 years ago.
GUI error
Screenshot-03.png Download (54.4 KB) - added by burdi01 3 years ago.
VBoxHeadless error

Change History

comment:1 Changed 3 years ago by burdi01

Hmmm, my 2.6 MB attachment is refused ...

Changed 3 years ago by burdi01

Settings and logs

comment:2 Changed 3 years ago by burdi01

Removed the screenshots from my attachment ...

Changed 3 years ago by burdi01

GUI error

Changed 3 years ago by burdi01

VBoxHeadless error

comment:3 Changed 3 years ago by frank

I think only a  core dump can help us to debug this problem. If you can provide one, feel free to contact me via frank _dot_ mehnert _at_ oracle _dot_ com.

comment:4 Changed 3 years ago by burdi01

The VirtualBox dump is 60.7 MB, the VBoxHeadless one 38.5 MB

comment:5 Changed 3 years ago by burdi01

Recreated the dumps to get a companion VBox.log. I could not locate a log for VBoxHeadless ...

comment:6 Changed 3 years ago by frank

Thanks for the core dumps. Both core dumps show that something goes wrong when initializing the ALSA sound backend (calling snd_pcm_open()). So disabling the sound should work around these SEGFAULTs. Trying to switch to the PulseAudio backend might be worth trying as well.

On the other hand it is difficult to say why it crashes there because Ubuntu does not ship debug symbols for the alsa library.

comment:7 Changed 3 years ago by frank

Did some older VBox version work without these crashes?

comment:8 Changed 3 years ago by burdi01

Disabling audio indeed works around the problem.

I reenabled audio and tested with the sundry host audio drivers and audio controllers:

Local X:
====
Null : start ok, no sound
OSS : HostAudioNotResponding, start ok, no sound
Pulse : HostAudioNotResponding, start ok, no sound
Alsa : start ok, has sound

VNC in:
====
Null : start ok, no sound
OSS : HostAudioNotResponding, start ok, no sound
Pulse : HostAudioNotResponding, start ok, no sound
Alsa : start segfault

Telnet in:
=====
Null : start ok, has sound
OSS : xcb_connection_has_error() returned true, start ok, has sound
Pulse : xcb_connection_has_error() returned true, start ok, has sound
Alsa : start segfault

SSH in:
====
Null : start ok, has sound
OSS : start ok, has sound
Pulse : start ok, has sound
Alsa : start ok, has sound

The Intel HD Audio controller was recognized as an Intel 82801 ICH6 HD Audio one.
The ICH AC97 controller was recognized as an Intel 82801AA AC'97 one.
Which one of these controllers was selected had no effect on the above results.
The SoundBlaster 16 controller was not recognized - which may or may not be caused by a missing driver.

Adding root to the vboxusers group had no effect.
Chosing the ICH9 motherboard instead of the PIIX3 one had no effect either.

Things certainly have worked before.
I first noticed the VNC problem with 4.0.12, and the then workaround was to telnet in run VBoxHeadless using the alsa host driver (succeeded 3 out of 4 times).
The last time before that which I am certain of to have used VNC in was in April/May, the then versions (4.0.4, 4.0.6 and 4.0.8) with the alsa host driver did not show the problem.

comment:9 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use