VirtualBox

Ticket #9493 (new defect)

Opened 3 years ago

Last modified 9 months ago

Samsung Galaxy not usable via USB filter

Reported by: USBProb Owned by:
Priority: major Component: USB
Version: VirtualBox 4.1.0 Keywords: USB filter not usable
Cc: Guest type: Windows
Host type: Windows

Description

My Samsung Galaxy S in USB mode "Samsung Kies" is not recognised in VirtualBox. Windows on the host reports device error. On a second try VBox recognises it as "SAMSUNG_Android" but then host reports "Unknown device".

Win 7 64bit host XP 32 Bit Guest

Change History

comment:1 Changed 3 years ago by eatmorchikin

I am also having a similar problem. Here is a thread in which my issue is discussed:

 https://forums.virtualbox.org/viewtopic.php?f=3&t=44953

comment:2 Changed 3 years ago by dkeefe3773

Ahh, finally found this ticket. I've been struggling with this for hours. So, yeah, same issue here. By the way, there is an earlier bug report for this exact same problem: #8186. (There is a workaround provided in the comment stream for that ticket, but it didn't work for me - that being to have another USB device installed before hooking up the phone).

My situation is a WIN7 64 bit host and fedora 14 64 bit client. I've tried both with and without the SAMSUNG USB driver for mobile phones. Tried with filters checked, unchecked. Tried mass storage mode / debug mode. Nothing works, as stated above.

comment:3 Changed 2 years ago by ssteph38

Hello,

Add my contrib on this as I faced this problems months ago.

I had and still have the same problem (as above in fact) here I added a post with logs :  https://forums.virtualbox.org/viewtopic.php?f=3&t=42929

The Usb Problem seems generalized to ALL Samsung devices but does not concerns other devices. I tested it on GalaxyTab 7, Samsung Google Nexus S. Not to say that on a real Linux box both devices works without problems.

Sad to say that under vbox with usb other devices like HTC work whereas Samsung devices do not !

comment:4 Changed 9 months ago by Iancdn

I have the same problem described here, getting my phone recognized by a guest. Nexus S. Win7-64 host, Ubuntu 12.04 guest, Vbox 4.2.16 v86992

I have tried with and without a USB filter active. I am using the USB 2 port on my Lenovo E430, but have also tried USB 3 port with same results.

No problem initially capturing the device, but it is never visible in lsusb.

Any progress on this problem?

Ian

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use