VirtualBox

Ticket #9489 (reopened defect)

Opened 3 years ago

Last modified 2 years ago

Win-XPpro hangs on shutdown

Reported by: Perryg Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I believe this issue started after some work was done on the absolute pointer, maybe in regards to some win 98 patching, but don't hold me to it. It is certainly affected in 4.0.12 and newer. It seems that if you try to power down an XP guest and the absolute pointer is activated in the guest settings Windows get all the way to the last and just hangs. You can click the red X and select to power down and it will finish the shutdown. Disabling the absolute pointer solves this. I can pass the guest logs but don't think you need them since the actual defect is known.

Others with issues:  http://forums.virtualbox.org/viewtopic.php?f=2&t=43822&start=0

Marked as major only because it is a major PITA but you can change it to what ever suites you since there is no just annoying priority.

Change History

comment:1 Changed 3 years ago by DawnLight

I don't know why this happens. It is not consistent in any way that I've seen so far.

comment:2 Changed 3 years ago by DawnLight

OK it is consistent. With absolute pointing device on shut down works. Restart seemingly reaches the point where the OS tells the hardware to restart and it stays on.

Absolute pointing device off = Restart works.

Cheers.

comment:3 Changed 3 years ago by Powzzz

This bug is confirmed. Guest hangs every time on "Windows is shutting down" if "Absolute pointing device" set to on. Windows XP SP2/3 (32-bit) guest on Win7 x64 host.

comment:4 Changed 3 years ago by BrianJM

This bug is confirmed with Windows Server 2003 as the guest in VirtualBox 4.1.2.

comment:5 Changed 3 years ago by anybody

Not yet fixed in VirtualBox 4.1.4 :-(

comment:6 Changed 3 years ago by frank

Did you update the Guest Additions?

comment:7 Changed 3 years ago by anybody

Shame on me!

I had indeed not done that, and that is of course what actually solved problem :-) I've tried lots of reboots and 4 shutdowns and they all worked perfectly now with the absolute pointing device enabled.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

That's are good news, thanks for the feedback!

comment:9 Changed 2 years ago by dewijant

  • Status changed from closed to reopened
  • Resolution fixed deleted

This problem is not solved.

I use Virtual Box with Windows Server 2003 as guest and shutdown sometime works sometime not :(. Host OS is Windows Server 2008. I disabled absolute pointing device.

I use Virtual Box 4.1.6

Last edited 2 years ago by dewijant (previous) (diff)

comment:10 Changed 2 years ago by Lauscher

I'm using a physical installed XP both physical and virtual using raw disk access. This problem has been both in physical and virtual mode of XP. After disabling absolute pointing device the problem dissapears in virtual mode, but it is still there in physical mode. So I think the issue can be found inside of the guest additions, because VirtualBox is not present in physical mode except by the installed guest additions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use