VirtualBox

Ticket #9439 (closed defect: fixed)

Opened 3 years ago

Last modified 19 months ago

WDDM Driver does not render desktop

Reported by: nguyer Owned by:
Priority: minor Component: WDDM
Version: VirtualBox 4.1.0 Keywords: aero, wddm
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by frank) (diff)

I am using a Mac OS 10.7 host. It has a Intel HD Graphics 3000 384 MB graphics chip.

I have a Windows 7 Professional 64bit guest with VirtualBox Additions installed, and 3D acceleration enabled (with the WDDM driver installed). I have provided the VM 128MB of video memory, as required. When I enable the Windows 7 Aero theme, all I can see is a blue background. I am unable to see the desktop or any of the open windows. However the mouse cursor is still visible. Please see attached screenshot. The machine does not crash, and I am able to switch back to Aero Basic.

I suspect this issue is related to the Intel HD Graphics 3000, rather than the fact that it is running on a Mac. On my other computer (A Windows 7 64bit host), running an NVidia 9800GTX+ this problem does not occur.

Attachments

aero-basic.jpg Download (222.1 KB) - added by nguyer 3 years ago.
Aero Basic running normally
aero-glass.jpg Download (68.4 KB) - added by nguyer 3 years ago.
Aero glass theme not rendering properly

Change History

Changed 3 years ago by nguyer

Aero Basic running normally

Changed 3 years ago by nguyer

Aero glass theme not rendering properly

comment:1 Changed 3 years ago by ondrej

I can repro this on a 2011 MBA.

comment:2 Changed 3 years ago by oreru

Could reproduce this on OSX 10.6 with Intel HD Graphics 3000 chip.

comment:4 Changed 3 years ago by oreru

wacher, I'm not sure these two issue are related; in this ticket Aero _does_ start and "work" from a driver point of view. But the actual output is somehow corrupted.

comment:5 Changed 3 years ago by wacher

I think in this ticket Aero _partially_ work because of Mac OS. In the forum topics Aero doesn't work at all because of Win. The common component is the Intel GA.

comment:6 follow-up: ↓ 7 Changed 3 years ago by oreru

Make sense! I don't know if the issue is related, but when the wddm driver is installed, video does not show in media player, with or without 2d acceleration. The result is totally transparent where the draw surface should be.

comment:7 in reply to: ↑ 6 Changed 3 years ago by nguyer

Replying to oreru:

Make sense! I don't know if the issue is related, but when the wddm driver is installed, video does not show in media player, with or without 2d acceleration. The result is totally transparent where the draw surface should be.

I have seen similar issues with applications like Java based apps and IE 9, where they have a completely blank window. Usually it’s just a solid white background. This happens with the WDDM driver installed, but using the Aero basic theme. I’m not sure if it’s the same issue, but it seems related.

comment:8 Changed 2 years ago by wacher

Maybe Intel graphics and VB aren't friends... Here is a new Intel related issue:  https://forums.virtualbox.org/viewtopic.php?f=2&t=45456

comment:10 Changed 2 years ago by oreru

Still defective in 4.1.6

comment:11 Changed 2 years ago by dan542

Same here - MacBook Pro 13" Early 2011, Intel Core i7 2.7GHz, Intel HD Graphics 3000, Mac OS X Lion

comment:12 Changed 2 years ago by frank

  • Component changed from other to WDDM

comment:13 Changed 2 years ago by oreru

Is it possible to change priority on this one? it is largely more important than "my glass effect is not 100% accurate"'s likes. Thank you for your consideration.

comment:14 Changed 2 years ago by cowman

I have the same on my early MBP i5 with Intel HD Graphics 3000. It seems DirectX3D is not properly supported. Anyone has workarounds? I would like to stick with VirtualBox.

comment:15 Changed 2 years ago by elaborateruse

I am experiencing the same issue as the others in this thread. MBP i5 with Intel HD Graphics 3000.  This one. As the others said, the UI is still responsive to clicks, etc. while the graphics are funny. I thought I caused the issue at first by accidentally installing the basic Direct3D driver in Safe Mode before installing the WDDM driver in standard mode. Apparently, the issue is more widespread, so thanks in advance VB team!

comment:16 Changed 2 years ago by oreru

Still present in 4.1.8

comment:17 Changed 2 years ago by wacher

4.1.10 It's working for some user.  https://forums.virtualbox.org/viewtopic.php?f=6&t=48093 I can use Aero for some seconds, the virtual machine crash after switching to an Aero theme.

comment:18 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

There were a lot of fixes for the WDDM driver in between. Please update to VBox 4.1.22 / 4.2.0 (including the Guest Additions).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use