Ticket #9395 (closed defect: fixed) — at Version 5

Opened 8 years ago

Last modified 6 years ago

Crash with WDDM driver on Windows 7 guest

Reported by: mduft Owned by:
Component: 3D support Version: VirtualBox 4.1.0
Keywords: wddm Cc: markus.duft@…
Guest type: Windows Host type: Linux

Description (last modified by frank) (diff)


I wanted to give the new WDDM driver a test shot with aero on a windows 7 guest. the driver installed without a problem, but after rebooting, choosing the aero design in "appearance" caused a crash of dwm.exe (sorry, no more details for that one...).

After that crash, i tried to do the windows performance assessment, which caused the VM to abort (!) :). attached is the according log file for that session.

HTH, Markus

Change History

Changed 8 years ago by mduft

log of aborted vm

comment:1 Changed 8 years ago by mduft

found one more thing for the reported crash in /var/log/messages:

Aug  8 11:11:22 s01en22 kernel: [  725.560792] VirtualBox[7506]: segfault at 2a ip b16e3960 sp b17dcd40 error 4 in[b169f000+b4000]

i tried again, and hat to emergency reboot the host (!) through sysrq keys. what i did:

i booted the machine. the VM windows (dual-monitor) where maximized on my two monitors. the vm contents however was only 800x600 (or 1024x786? whatever; it was lower than the window's size) (since windows defaults to that with the new hw..?). i activated aero, and it indeed started correctly this time.

i tried to minimize and restore the appearance setting window to test the aero effects, which caused a strange artifact on the second monitor (a black rectangle approx. the size of the window i just minimized on the primary monitor).

after that i wanted to change the resolution to fit the maximized vm window. i have auto-resize on, so i just wanted to restore and re-maximize the window on the host to make it auto-adapt the the resolution. however, after i double clicked the window on the host, it snapped to a very small resolution (below 640x480, i guess), and the host immediately froze completely.

i tried to get back to a VT by putting the keyboard into raw mode (alt sysrq r, ctrl alt f1), but that didn't work, nothing reacted.

the syslog only shows my attempts to sysrq-reboot the machine, nothing obviously wrong.

the Xorg log shows one of my favorite X crashes in conjunction with virtualbox (never saw the crash with anything else):

[  2193.191] (WW) NVIDIA(0): WAIT (0, 6, 0x8000, 0x00006050, 0x00006050)
[  2201.208] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00006870, 0x0000e310)
[  2201.743] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[  2201.743]
[  2201.743] 0: /usr/bin/X (xorg_backtrace+0x3c) [0x80ea48c]
[  2201.743] 1: /usr/bin/X (mieqEnqueue+0x1a0) [0x80e9da0]
[  2201.743] 2: /usr/bin/X (xf86PostMotionEventM+0xbd) [0x80c541d]
[  2201.743] 3: /usr/bin/X (xf86PostMotionEventP+0x59) [0x80c5559]
[  2201.743] 4: /usr/lib/xorg/modules/input/ (0xb4cbe000+0x45ce) [0xb4cc25ce]
[  2201.743] 5: /usr/lib/xorg/modules/input/ (0xb4cbe000+0x4868) [0xb4cc2868]
[  2201.743] 6: /usr/bin/X (0x8048000+0x6b510) [0x80b3510]
[  2201.743] 7: /usr/bin/X (0x8048000+0x12588a) [0x816d88a]
[  2201.743] 8: (vdso) (__kernel_sigreturn+0x0) [0xb773c400]
[  2208.208] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00006870, 0x0000e310)
[  2216.271] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00006870, 0x0000e320)
[  2223.271] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00006870, 0x0000e320)
[  2231.339] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00006870, 0x00003e80)
[  2238.339] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00006870, 0x00003e80)
[  2243.406] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[  2243.406]
[  2243.407] 0: /usr/bin/X (xorg_backtrace+0x3c) [0x80ea48c]
[  2243.407] 1: /usr/bin/X (mieqEnqueue+0x1a0) [0x80e9da0]
[  2243.407] 2: /usr/bin/X (xf86PostMotionEventM+0xbd) [0x80c541d]
[  2243.407] 3: /usr/bin/X (xf86PostMotionEventP+0x59) [0x80c5559]
[  2243.407] 4: /usr/lib/xorg/modules/input/ (0xb4cbe000+0x45ce) [0xb4cc25ce]
[  2243.407] 5: /usr/lib/xorg/modules/input/ (0xb4cbe000+0x4868) [0xb4cc2868]
[  2243.407] 6: /usr/bin/X (0x8048000+0x6b510) [0x80b3510]
[  2243.407] 7: /usr/bin/X (0x8048000+0x12588a) [0x816d88a]
[  2243.407] 8: (vdso) (__kernel_sigreturn+0x0) [0xb773c400]

i'll attach the log for the session that crashed the host too.

Changed 8 years ago by mduft

second crash - this time the host was gone...

comment:2 Changed 8 years ago by mduft

now for the third try:

this time the vm aborted immediately when i tried to apply the aero theme after bootup.

the log again shows the line already previously seen:

00:01:01.736 OpenGL Error: Assertion failed: conn->pHostBuffer && !conn->cbHostBuffer, file /home/vbox/tinderbox/lnx32-rel/src/VBox/GuestHost/OpenGL/util/vboxhgcm.c, line 568

and the syslog shows another crash (different location now though):

Aug  8 11:53:55 s01en22 kernel: [  962.929532] VirtualBox[7631]: segfault at 938 ip b50b6b58 sp b1854e60 error 4 in[b422e000+16b4000]

comment:3 Changed 8 years ago by mduft

with the fourth try, i was able to activate aero again. this time i was able to screenshoot the artifact i described before; also you can see how the window(s) and vm contents where lay out with the previous crashes.

a try to get the full resultion failed again. but this time, the vm keeps running, and the screen turns black. no way to interact with the vm anymore. when i do an ACPI shutdown, the "shutting down" appears again and the vm shuts down normally. starting the vm thereafter finally gives me full resolution aero.

so far the only persisting problem (for this single session ;)) is, that the window contents during effects is not rendered correctly. if i minimize a window, the contents of the window is not shown throughout the animation, but only a black rectangle is "animated" (the shadow of that black rectangle seems ok though, so just the window turns black during all animations).

comment:5 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.10.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use