Ticket #9376 (closed defect: obsolete)

Opened 7 years ago

Last modified 22 months ago

USB error ald is invalid (must be Guid(ald).isEmpty() == false

Reported by: jimlaurent Owned by:
Priority: major Component: USB
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by aeichner) (diff)

Running MacOS 10.7 host and VirtualBox 4.1 with a Windows XP client.

Insert a Seagate external disk formatted by MacOS into USB. Selecte Seageate (0130) from Devices USB menu.

Failed to attach the USB device unknown device to the virtual machine. Received the error Argument lad is invalid (must be Guid(lad).isEmpty() == false.

Caller RC ns_error_call_failed (0x800706be)

I am planning to run the Seagate Seatools to diagnose a hardware issue on the drive but unable to attach the drive.


VBox.log Download (95.2 KB) - added by ddan 7 years ago.
Seagate Profile.txt Download (551 bytes) - added by Jahava 6 years ago.
Profile of failing 1TB External Drive

Change History

comment:1 Changed 7 years ago by lectroidmarc

Seeing exactly the same with 4.1.0 on both 10.6 and 10.7 host with a Linux client.

Changed 7 years ago by ddan


comment:2 Changed 7 years ago by ddan

Same here (Mac OS 10.7 with Windows XP client). The issue is re-produceable. This affects a Western Digital external hard disk drive with USB <> SATA controller and a Hitachi hard disk with USB <> IDE controller. A LaCie hard drive works although it took a lot of time for detecting the device.

comment:3 Changed 7 years ago by ddan

Output of VBoxManage list usbhost:

UUID:               dc1638a7-91c6-45ce-986c-f628b9a003b6
VendorId:           0x0840 (0840)
ProductId:          0x0060 (0060)
Revision:           17.1 (1701)
Manufacturer:       USB2.0 TO IDE
Product:            USB Storage Adapter
SerialNumber:       11100E00005EC6B7
Address:            p=0x0060;v=0x0840;s=0x00000dd499d3b750;l=0xfd100000
Current State:      Unavailable

UUID:               b3056896-9299-452f-9b2f-fecf8f155b79
VendorId:           0x1058 (1058)
ProductId:          0x0702 (0702)
Revision:           1.4 (0104)
Manufacturer:       Western Digital
Product:            External HDD
SerialNumber:       575845593037523139353837
Address:            p=0x0702;v=0x1058;s=0x00000dd18af3d3c4;l=0xfa200000
Current State:      Unavailable

comment:4 Changed 7 years ago by kyvlle

Same problem. Guest: Windows XP Service Pack 3, Host: Mac OS X 10.6.8.

comment:5 Changed 7 years ago by ddan

This is not fixed in 4.1.2 r73507:

Das USB-Gerät Unbekanntes Gerät konnte nicht an die virtuelle Maschine  gebunden werden.


After this error message all the settings were not displayed. Every window is empty but the buttons (Cancel, OK). If you need anything specific please let me know!

comment:6 Changed 6 years ago by kamalx

I observe exactly the same issue as ddan (comment:5) with a 500G Western Digital external hard drive on Mac OS X 10.7.3. VBox version 4.1.10 r76795 running Ubuntu 11.10 as guest.

It worked for me before the last VBox update happened couple of days ago, however it was flaky; i couldn't say for sure it would mount each time.

After the last update, the HDD is invariably taken by the host OS. Once I unmount from the host, the VM devices menu goes blank, so does each and every settings (or other) dialog, with only OK and Cancel buttons showing up. Also, the Cancel button at this point does not do anything, OK closes the blank dialogs that used to have settings screens in them earlier. Whenever this happens, the VM shows the guest OS as running even after it apparently shuts down cleanly; and if the VBox window is closed (it never changes the running status regardless of how long i wait for it after shutdown), it shows the guest OS status as Aborted instead of Powered off.

Trying to mount the external hard drive at some point immediately after plugging it in showed me an error with this info: Callee RC: NS_ERROR_CALL_FAILED (0x800706BE)

Just about at that point, it gets mounted on the host (Mac OS X 10.7.3)

Please let me know if I can provide some more information that might help.

Version 0, edited 6 years ago by kamalx (next)

Changed 6 years ago by Jahava

Profile of failing 1TB External Drive

comment:7 Changed 6 years ago by Jahava

I'm also experiencing the same problems described by kamalx (comment:6). I'm using:

  • Mac OSX version 10.7.4
  • VirtualBox version 4.1.18 r78361, as well as the Oracle VM VirtualBox Extension Pack of the same version/revision.

I've tried connecting a series of external USB drives, including:

  • Western Digital 750MB External
  • Seagate 3TB External
  • Seagate 1TB External (OSX Profile attached)

The general procedure is the same:

  • 1) Connect the drive; it is detected by OSX. Looking at the USB menu in VirtualBox, the drive is gray.
  • 2) Eject the drive from OSX; the drive is no longer gray in the USB menu.
  • 3) Use the USB menu to connect the drive to a VirtualBox instance. The drive fails with NS_ERROR_CALL_FAILED.
  • At this point, the virtual machine seems to disconnect from central VirtualBox. While the VM seems to run just fine, many dialogues fail. I effectively have to shutdown the VM and terminate all VirtualBox instances before it resets its internal state.

I have tried everything from filters to killing the IOKit detection and haven't managed to reliably connect a drive to VirtualBox save through the "createrawvmdk" option directly linking to hardware. While this solution hasn't panned out as reliable, it is the closest I've gotten to having an external USB hard drive connect directly to a VM (rather than as a share through my host). Please give this problem a priority; I'd love a reason to delete my Linux dual-boot on my Mac.

Please let me know if there's any profiling or steps that I can take to get this resolved. I know my way around computers, kernels, and development in general, and I would be happy to lend any help that I can to resolving this issue.


comment:8 Changed 22 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use