VirtualBox

Ticket #9368 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Invalid Settings warning after enabling Remote Display

Reported by: iridris Owned by:
Priority: trivial Component: other
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

If the Remote Display option is turned on, but no server port specified, there will be a red warning message stating "Invalid Settings" with no description as to what setting is invalid.

To recreate this scenario (method A):

  1. Open the settings window of a VM
  2. Go to Display > Remote Display
  3. Check the 'Enable Server' box
  4. The message will be displayed while the 'Server Port' field is empty.

To recreate this scenario (method B):

  1. Start a VM
  2. From the VM window, go to Devices > Enable Remote Display
  3. Stop the VM
  4. Open the settings for the VM
  5. Observe that the 'Invalid Settings' message is displayed, with no indication as to what setting.

Note that this is really only a problem when method B is used, as in this scenario the user may not make the connection that the message was caused by enabling the remote display. This happened to me and it was several days before I opened the settings window after having enabled the remote display, and I had to manually toggle each option until I found the culprit.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the report and the detailed description. This problem is fixed in VBox 4.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use