VirtualBox

Changes between Initial Version and Version 1 of Ticket #9364, comment 6


Ignore:
Timestamp:
04/13/12 06:07:36 (2 years ago)
Author:
frank
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #9364, comment 6

    initial v1  
    22 
    33Single snapshot.  Booted the VM briefly so it was changed, then shutdown and attempted to restore the snapshot.  Segfault: 
    4  
     4{{{ 
    55#0  std::list<ComObjPtr<MediumAttachment>, std::allocator<ComObjPtr<MediumAttachment> > >::remove (this=0x0, __value=...) 
    66    at /portbuild/portage/app-emulation/virtualbox-4.1.12/work/VirtualBox-4.1.12/src/VBox/Main/src-server/MachineImpl.cpp:12926 
     
    1010#2  0x00000000005296f9 in SessionMachine::taskHandler (pvUser=0x7f1ea8090bf0) 
    1111    at /portbuild/portage/app-emulation/virtualbox-4.1.12/work/VirtualBox-4.1.12/src/VBox/Main/src-server/SnapshotImpl.cpp:1334 
    12  #3  0x00007f1ec370f13c in rtThreadMain (pThread=0x7f1ea802f630,  
     12#3  0x00007f1ec370f13c in rtThreadMain (pThread=0x7f1ea802f630,  
    1313    NativeThread=<optimized out>, pszThreadName=<optimized out>) 
    1414    at /portbuild/portage/app-emulation/virtualbox-4.1.12/work/VirtualBox-4.1.12/src/VBox/Runtime/common/misc/thread.cpp:703 
    15  #4  0x00007f1ec375b3ee in rtThreadNativeMain (pvArgs=0x7f1ea802f630) 
     15#4  0x00007f1ec375b3ee in rtThreadNativeMain (pvArgs=0x7f1ea802f630) 
    1616    at /portbuild/portage/app-emulation/virtualbox-4.1.12/work/VirtualBox-4.1.12/src/VBox/Runtime/r3/posix/thread-posix.cpp:255 
    17  #5  0x00007f1ec39d2d0c in start_thread () from /lib64/libpthread.so.0 
    18  #6  0x00007f1ec2789dbd in clone () from /lib64/libc.so.6 
    19  
     17#5  0x00007f1ec39d2d0c in start_thread () from /lib64/libpthread.so.0 
     18#6  0x00007f1ec2789dbd in clone () from /lib64/libc.so.6 
     19}}} 
    2020 
    2121After continuing, the UI immediately changed the VM name to Snapshot 1, and marked the VM inaccessible.  When I've seen this without gdb running, the UI pretends the snapshot was restored, but when I delete the snapshot, that's when it gets screwed up and marks the VM inaccessible. 

www.oracle.com
ContactPrivacy policyTerms of Use