VirtualBox

Ticket #934 (closed enhancement: fixed)

Opened 6 years ago

Last modified 3 years ago

Feature Request: Emulation of Text-Mode (DOS mode) in Full-Screen

Reported by: Technologov Owned by:
Priority: major Component: GUI
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Dalaunge and I think:

We'd like to have a Fullscreen in DOS... I mean, not a small window in the middle of the screen, and the rest ist "black border". I want a stretched Full-Screen mode.

Some further ideas on that topic:

I don't think that it's possible to do in an easy way. Correct emulation of DOS mode in Full-Screen I mean.

That is why: To emulate DOS Text-Mode, you need to emulate either 720x480 (I think) resolution on host, or Text-Mode on host.

In Windowed mode, emulating 720x480 window is not a problem (that's what VirtualBox does, but *it is* a problem in Full-Screen, because VESA standard has no such mode.

Of course it may be possible to emulate it via Text-Mode on host, but it has two problems:

  1. not all hosts support text-mode (Think of Linux with fbdev enabled)
  2. I don't think that VirtualBox BIOS/VideoBIOS is able to translate guest's text-mode into host's text-mode.

...so improving VirtualBox BIOSes might be required, as well as patches to Linux fbdev driver to allow switching into hardware text-mode. (or simply ask the user via VirtualBox Documentation to disable fbdev driver when running Linux host). On Windows host, there is no fbdev problem. Something similar to the Linux fbdev problem also exists for Mac hosts.

Currently VirtualBox (and other virtualizers) have ugly approximation of DOS mode in Fullscreen.

-Technologov, 30.11.2007.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:2 Changed 6 years ago by bram85

This is a duplicate of ticket 912.

comment:3 Changed 6 years ago by sandervl73

  • Summary changed from Emulation of Text-Mode (DOS mode) in Full-Screen to Feature Request: Emulation of Text-Mode (DOS mode) in Full-Screen

More info here, so I marked 912 as a duplicate of this one.

comment:4 Changed 5 years ago by oldbushie

This isn't just a DOS problem... there's a lot of old Windows games as well that force you into 640x480 with no means of "2x scaling" the pixels to make it fit modern monitors. It's painful to have to lean within 6 inches of my monitor to see what's going on. Fullscreen would be a lot trickier, but if ther ewere 2x scaling I'd be very happy.

comment:5 Changed 5 years ago by Technologov

This bug originally was about 80x25 text-mode, but you started to extend it to graphical modes too... so let's talk about ideas:

Yes, 2x scaling is very basic necessary feature, can be done easily in software.

However since VBox 3.x is into OpenGL, it is possible VBox could provide advanced rendering; I.e. render any guest resolution into texture, and do real-time scaling using 3D GPU. Maybe software technologies exist to do smooth real-time scaling without GPU, by using multiple buffers, by increasing delay.

Additional problem is aspect ratio - most legacy software expect 4:3 ratio, while modern monitors are wide-screen, and use 16:10 ratio.

This can be solved by optionally (must be configurable) either stretching the image (making images ugly, but using all monitor real estate), or leave black fields at the end of monitors (making images look correct, but sacrificing some monitor real estate).

Personally I prefer to get correct image, by sacrificing some monitor real estate. (and I recommend using this by default)

-Technologov, 4.8.2009.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VBox 4.0 introduces a scaling mode. This is perhaps not exactly the original request but it should be sufficient.

comment:7 Changed 3 years ago by Technologov

Actually original feature request is useless anyway on today's LCD monitors, because they do not support hardware text mode (80x25), but emulate it anyway. So this original feature-request is no longer relevant, due to lack of hardware.

Original feature-request is meant to be for CRT monitors, where hardware text-mode support makes sense.

-Technologov, 28.02.2011.

comment:8 Changed 3 years ago by oldbushie

Awesome, thanks!! Now I can play Puzz-3D with a much bigger resolution. :D It kept forcing the game size to 640x480 otherwise.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use