VirtualBox

Ticket #9336 (closed defect: invalid)

Opened 3 years ago

Last modified 2 years ago

vboxwebsrv memory usage in Ubuntu Server 11.04

Reported by: imoore76 Owned by:
Priority: major Component: webservices
Version: VirtualBox 4.1.0 Keywords: vboxwebsrv memory
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

I tried searching existing bug reports but didn't find anything.

vboxwebsrv memory usage seems to grow very quickly when calling the logon function. You can test this using webtest (from vbox source) logon / logoff. This does not happen on a Debian 6.0.2 box. I also notice that it does not happen if I set websrvauthlibrary to null. The debian box has websrvauthlibrary set to default.

As the author of a web frontend to VirtualBox, I've seen a few reports of this on my site. I had been unable to reproduce it until now.

 http://code.google.com/p/phpvirtualbox/issues/detail?id=179  http://code.google.com/p/phpvirtualbox/issues/detail?id=335  http://forums.virtualbox.org/viewtopic.php?f=7&t=42905

Let me know if I can provide any more information.

Change History

comment:1 Changed 3 years ago by imoore76

So errmm.. I tracked the memory leak down to libpam-smbpass (pam_smbpass.so). Sorry for not looking into it further before posting this report. You may close this. It really has nothing to do with virtualbox.

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use