VirtualBox

Ticket #933 (closed defect: worksforme)

Opened 6 years ago

Last modified 6 years ago

NAT works even when Network Adapter is disabled

Reported by: yojick Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords: NAT, host interface
Cc: Guest type: other
Host type: other

Description

I tried to make my guest OS working with Host Interface as described in your manual. So I diabled my Adapter # 1 (which previously worked with NAT) and enabled Adapter # 2 with Host Interface. I made necessary configuration (created tap0 and so on) and my guest OS successfully started and got an IP from DHCP server of our LAN. But I was unable to ping my guest machine neither from the host machine nor from any host in our LAN. Ping from my guest machine to my host machine or to LAN was successful. It was like my guest machine was behind NAT router, so I turned off my guest machine, enabled Adapter # 1 again, set it to "Not connected" mode and then disabled. After that my guest machine became reachable to host machine and to any LAN host =)

So, the bug is that guest machine is unreachable from outside even when adapter with NAT is disabled.

Change History

comment:1 Changed 6 years ago by frank

Please post the VBox.log file when you did the setup as described.

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response for months, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use