VirtualBox

Ticket #9301 (closed defect: fixed)

Opened 3 years ago

Last modified 20 months ago

PXE network boot with ICH9 chipset fails => Fixed in SVN

Reported by: bebilith Owned by:
Priority: minor Component: network
Version: VirtualBox 4.1.0 Keywords: chipset pxe
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

When trying to network boot with chipset set to ICH9, boot fails with "Unknown Ethernet Controller" error.

Error occurs regardless of NIC type selected.

v4.1.0 extensions are installed.

If chipset is changed to PIIX3, PXE works normally.

Attachments

VB Test boot-2011-07-25-09-38-28.log Download (47.1 KB) - added by bebilith 3 years ago.
VB Log of failed PXE boot
PXE boot failure.jpg Download (61.8 KB) - added by bebilith 3 years ago.
Screenshot of PXE boot failure

Change History

Changed 3 years ago by bebilith

VB Log of failed PXE boot

Changed 3 years ago by bebilith

Screenshot of PXE boot failure

comment:1 Changed 3 years ago by Pegasus

Same thing happens to me as well.

comment:2 Changed 3 years ago by EqUaTe

Confirmed. Meant to report this last week! Apparently this is due to ICH9 being under heavy development and incomplete.. Hopefully this'll be changed soon!

comment:3 Changed 2 years ago by gxyz

Are there any news regarding this issue?

Unfortunately, for my purposes it's a show-stopper - after it was clear that this is a general problem with virtualbox 4.1, I reverted to 4.0 and occasionally checked this bug report. There has not been any update here, but I'm not sure whether this means that the problem still persists ...

comment:4 Changed 2 years ago by jkb

I can confirm what gxyz told. With Version 4.1.8 running under Gentoo Linux (64 Bit) this error can still be observed. For me it's really pain, since I rely on using ICH9 chipset allowing me to configure multiple SCSI controllers which is a must for my purposes while needing the ability to perform PXE network boots. Simply consider using Solaris OS, simulating SANs via multiple SCSI controllers in conjunction with Jumpstart installations ... I am therefore trapped too with lower version 4.0.12 where all this works fine. I would really appreciate to get a statement about the current status of this ticket since it is still not assigned to anybody. Thank you very much.

comment:5 Changed 22 months ago by Mace2442

Problem remains with 4.1.8 on Windows Host. Have Oracle Extensions installed.

With ICH9 no network adapter works for PXE.

comment:6 Changed 22 months ago by frank

  • Description modified (diff)
  • Summary changed from PXE network boot with ICH9 chipset fails "Unknown Ethernet controller" to PXE network boot with ICH9 chipset fails => Fixed in SVN

Thanks for the report. This bug will be fixed in the next maintenance release. But please be aware that the ICH9 chipset is marked as experimental.

comment:7 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The fix is part of VBox 4.1.20.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use