VirtualBox

Ticket #9283 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

EFI boot not working on Solaris host after 3.2.12

Reported by: baro Owned by:
Priority: major Component: EFI
Version: VirtualBox 4.1.0 Keywords: EFI Solaris
Cc: Guest type: OSX Server
Host type: Solaris

Description

I am running a Solaris 11 (snv_151a) host and have been able to boot and run a Snow Leopard guest in VirtualBox 3.2.12 and earlier. Ever since Virtual Box 4.x this guest has not been able to boot. I have tried 4.0.4, 4.0.6, 4.0.8, 4.0.10, and 4.1.0 and have not been able to boot. I have even tried creating a new VM from scratch. In every failing case, the VM crashes before the Vbox splash screen.

In all cases (existing image or from scratch) the first failure in the log on 4.1.0 is the same:

VMSetError: /home/vbox/tinderbox/sol-rel/src/VBox/VMM/VMMR3/VM.cpp(362) int VMR3Create(uint32_t, const VMM2USERMETHODS*, void (*)(VM*, void*, int, const char*, unsigned int, const char*, const char*, va_list_tag*), void*, int (*)(VM*, void*), void*, VM); rc=VERR_FILE_NOT_FOUND

I have attached the log from 4.1.0 when I attempted to create and boot a VM from scratch. I was able to create but not boot the VM (never saw the splash screen).

Attachments

OSX2-2011-07-23-00-12-31.log Download (1.6 KB) - added by baro 3 years ago.
Vbox log file when creating OSX guest from scratch and trying to boot.

Change History

Changed 3 years ago by baro

Vbox log file when creating OSX guest from scratch and trying to boot.

comment:1 Changed 3 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to invalid

OS X guests are only supported on Apple hardware due to Apple licensing restrictions. We do not support OS X guests on other hardware.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use