VirtualBox

Ticket #9282 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

virtualbox 4.1.0 vboxdrv causes kernel panic when hibernating with Linux 2.6.36 + tuxonice

Reported by: onexused Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.0 Keywords: kernel panic, module, modules, vboxdrv, Linux
Cc: Guest type: other
Host type: other

Description

I'm using Linux kernel 2.6.36 patched with the latest tuxonice. The virtualbox modules I have were generated with /etc/rc.d/vboxdrv setup . When I attempt to hibernate, the kernel panics during the "Doing atomic copy/restore" portion. The image has already been created by this point, and attempting to resume from it also causes a panic. Attempting to hibernate without vboxnetadp or vboxnetflt inserted, but with vboxdrv has the same results. Attempting to hibernate with none of the vbox modules inserted is successful, as is resuming from this image. There is no problem hibernating or resuming from an image with the drivers from virtualbox-4.0.8 inserted.

$ uname -a
Linux localhost 2.6.36-tuxonice-r4 #7 SMP PREEMPT Sun May 15 05:48:12 EDT 2011 i686 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz GenuineIntel GNU/Linux

What other information would be found useful to resolve this?

Change History

comment:1 Changed 3 years ago by fm

onexused are you trying to hibernate your hostsystem?

I am not running TuxOnIce however with VirtualBox 4.0.8 I never had problems to suspend to RAM with VirtualBox 4.1.0 I get almost allways a kernel panic.

$ uname -a Linux thinkpad 2.6.38.8-35.fc15.i686.PAE #1 SMP Wed Jul 6 14:29:06 UTC 2011 i686 i686 i386 GNU/Linux

comment:2 Changed 3 years ago by fm

ticket #9286 is a duplicate of this i guess.

btw. can I really not add myself to CC: of this issue??

comment:3 Changed 3 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9305.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use