VirtualBox

Ticket #9264 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Solaris upgrade to 4.0.12 fails with GA/shared folders => Fixed in SVN

Reported by: marshals Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.12 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description (last modified by ramshankar) (diff)

I have a Solaris 5.10 Generic_141445-09 i86pc machine that is not updating to 4.0.12 properly for some reason. It seems to be a GA problem wrt shared folders. I have a shared folder mounted to /export/home/share.

If I boot the VM with 4.0.12 VB but 4.0.10 GA:

With the machine settings untouched, the VM boots fine and it can see its shared folder. See log VBox-A.

With the sole shared folder removed via the VMM, the VM reports on booting:

WARNING: sfprov_mount: vboxCallMapFolder() failed
wvc:/system/filesystem/local:default: WARNING: /sbin/mountall -l failed: exist status 1
[...] svc:/system/filesystem/local:default: Method "/lib/svc/method/fs-local" failed with exit status 95.
[...] /system/filesystem/local:default failed fatally: transitioned to maintenance (see 'svcs -xv' for details)

and the guest does not start X11. I can log into the console however. See log VBox-B.

If I boot the VM with 4.0.12 VB and 4.0.12 GA (installed via the above VBox-A boot), I get the same problem as above for the above B boot. See log VBox-C.

This is how I first came across the problem: rebooting after re-installing GA. I tried going back to a snapshot and reinstalling 4.0.12 GA (pkgrm SUNWvboxguest/pkgadd -G -d ./VBoxSolarisAdditions.pkg) several times with the same result on reboot.

Attachments

VBox-A.log Download (50.9 KB) - added by marshals 3 years ago.
VBox-B.log Download (50.5 KB) - added by marshals 3 years ago.
VBox-C.log Download (50.8 KB) - added by marshals 3 years ago.

Change History

Changed 3 years ago by marshals

Changed 3 years ago by marshals

Changed 3 years ago by marshals

comment:1 Changed 3 years ago by ramshankar

  • Description modified (diff)

comment:2 follow-up: ↓ 3 Changed 3 years ago by ramshankar

If I understood the report right, you're saying removing a sharedfolder and booting an S10 VM causes X11 not to start?

Could you please provide /var/adm/messages from the guest. How are you mounting the shared folder? Have you added some line to /etc/vfstab ? Are you using automount?

comment:3 in reply to: ↑ 2 Changed 3 years ago by marshals

Replying to ramshankar:

If I understood the report right, you're saying removing a sharedfolder and booting an S10 VM causes X11 not to start?

X11 fails to start, and I get the above errors in the console, if (i) I use VB 4.0.12 with a VM that has GA 4.0.12 (apparently) successfully installed or (ii) I use VB 4.0.12 with a VM that still has GA 4.0.10 but where I have removed the shared folder via the VMM before booting.

If I use VB 4.0.12 with a VM that still has GA 4.0.10, I can boot normally and see the shared folder as normal.

Could you please provide /var/adm/messages from the guest. How are you mounting the shared folder? Have you added some line to /etc/vfstab ? Are you using automount?

Getting that log (and the output of svcs -xv) out of the guest is not easy - the guest cannot load module vboxfs. Is there somewhere I can ftp to?

I have the following in /etc/vfstab:

share - /export/home/share vboxfs - yes -

So I assume I just did a mount whenever I set it up.

comment:4 follow-up: ↓ 5 Changed 3 years ago by ramshankar

Boot the VM with NAT, and you can scp the file to your host (if it has sshd running) with scp <file> hostuser:@10.0.2.2: You can even copy/paste the file data over shared clipboard if you don't have network setup.

Solaris guest additions (shared folders only) for 4.0.12 is broken due to a regression (/var/adm/messages should show something along the lines of missing ctf symbols). I want the log just to verify that this is the case.

You could essentially grep for "ctf" , see  http://forums.virtualbox.org/viewtopic.php?f=20&p=194335

comment:5 in reply to: ↑ 4 Changed 3 years ago by marshals

Replying to ramshankar:

Boot the VM with NAT, and you can scp the file to your host (if it has sshd running) with scp <file> hostuser:@10.0.2.2: You can even copy/paste the file data over shared clipboard if you don't have network setup.

Thanks for the pointer, though my host is win7 and I haven't been able to get the shared clipboard to work.

Solaris guest additions (shared folders only) for 4.0.12 is broken due to a regression (/var/adm/messages should show something along the lines of missing ctf symbols). I want the log just to verify that this is the case.

Hmmm, I don't have anything like that. In fact, nothing obviously down to vbox. However, if I try to mount my share, I do get the above missing ctf symbols stuff, along with:

WARNING: mod_load: cannot load module 'vboxfs'

OK, I guess I'll leave it until the next release, I guess I can mostly reliably use 4.0.12 VB with 4.0.10 GA, right?

comment:6 follow-up: ↓ 7 Changed 3 years ago by ramshankar

Yes 4.0.10 additions have working shared folders (just auto-mount feature doesn't work), it's only 4.1.0 and 4.0.12 that has b0rked vboxfs (doesn't load due to missing symbols).

This has already been fixed and will be available in the next VBox release.

comment:7 in reply to: ↑ 6 Changed 3 years ago by marshals

Replying to ramshankar:

Yes 4.0.10 additions have working shared folders (just auto-mount feature doesn't work), it's only 4.1.0 and 4.0.12 that has the b0rked vboxfs that doesn't load due to missing symbols.

This has already been fixed and will be available in the next VBox release.

Thanks for your help. Pity u-ra didn't raise a ticket - I looked there for an existing one before I raised mine but not the forums. Gah.

comment:8 Changed 3 years ago by frank

  • Summary changed from Solaris upgrade to 4.0.12 fails with GA/shared folders to Solaris upgrade to 4.0.12 fails with GA/shared folders => Fixed in SVN

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 4.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use