VirtualBox

Ticket #9246 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

IDE controller is required? => Fixed in SVN

Reported by: wacher Owned by:
Priority: minor Component: GUI
Version: VirtualBox 4.1.0 Keywords: IDE controller
Cc: Guest type: Windows
Host type: Windows

Description

I created a new VBox configuration (for Windows 7), but I can't remove IDE controller. When I save the settings, GUI shows an error message:

Failed to save the settings of the virtual machine .......

No storage device attached to slot -1 on port -1 of controller IDE controller.

Result Code: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001) Component: SessionMachine Interface: IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}

No storage on IDE? Okay, but I want no IDE controller at all.

I can save the configuration with an empty IDE controller (no attached devices), but I can't remove the IDE controller itself.

No vbox.log, machine not started yet there are configuration steps.

Attachments

IDE_mystery.vbox Download (6.5 KB) - added by wacher 3 years ago.
mysterious IDE controller

Change History

comment:1 Changed 3 years ago by frank

I just tried this: Create a Windows 7 VM including a 20GB hard disk, remove the CD/DVD-ROM drive, remove the IDE controller. There was only one warning when removing the CD/DVD-ROM drive, but I was actually able to remove the IDE controller. Which VBox version are you using, is this really 4.1.0 or is it some 4.1.0 Beta?

comment:2 Changed 3 years ago by wacher

VboxManage.exe --version 4.1.0r73009

Strange... I created a new one. Everything is OK, I can save the settings without IDE controller too. I created a third new one, OK.

But the old one is still "wrong".

I think let's close this ticket as invalid, but I preserve this machine very carefully :)

comment:3 Changed 3 years ago by frank

Could you attach the .vbox/.xml file of this machine?

Changed 3 years ago by wacher

mysterious IDE controller

comment:4 Changed 3 years ago by wacher

Hello frank,

Here is the root cause. I can reproduce the issue, please try this steps.

1) Create a new Win7 machine, leave all options default.

2) Open Settings, go to Storage section 2a) remove IDE controller 2b) add an empty CD/DVD to SATA controller press OK

3) I get the mentioned error.

I think the root cause is that I do "2a" and "2b" in one step.

If I separate this steps

  • I remove IDE controller
  • OK
  • I attach a CD/DVD to SATA
  • OK

than that's working without any issue.

comment:5 Changed 3 years ago by wacher

(Oops can I edit my sent post? There is some typo, wrong line-breaks, I hope you can decrypt it...)

comment:6 Changed 3 years ago by frank

No you can't but I could reproduce your steps. Thanks.

comment:7 Changed 3 years ago by marti-n

Had the same problem, but this worked for me :

1) Delete ALL the controllers 2) Close settings, and open it again 3) Add the SATA controller again 4) Close settings, and open it again 5) Add the devices on the SATA controller, and save

Had no errors with this steps, so apperantly you can't delete the IDE controller without deleting the SATA controller :S

comment:8 Changed 3 years ago by frank

  • Summary changed from IDE controller is required? to IDE controller is required? => Fixed in SVN

The fix will be available in the next maintenance release.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix contained in VBox 4.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use