VirtualBox

Ticket #9240 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Guru Meditation -2 (VERR_INVALID_PARAMETER) when starting nearly any VM

Reported by: CaptainFlint Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

After upgrading to 4.1.0 final I cannot start any of my Windows VMs - either existing or newly created. VirtualBox just crashes with Guru Meditation -2 (VERR_INVALID_PARAMETER) in log. Two non-Windows machines (Android and openSUSE 11.1) boot without crash, but it's hard to tell whether it's a general rule or just a coincidence.

Attachments

WinXP_VBox.log Download (172.8 KB) - added by CaptainFlint 3 years ago.
WinXP VM log (trying to install a new OS)
Win7_VBox.log Download (175.8 KB) - added by CaptainFlint 3 years ago.
Win7 VM log (trying to boot OS from virtual hard disk)
VBox_vt_07201918.log Download (159.4 KB) - added by wacher 3 years ago.
WinXP host + WinXP guest
VBox_WinXP_cxp_110720.log Download (142.8 KB) - added by wacher 3 years ago.
An other one occurence
Ubuntu-2011-07-20-12-42-19_.log Download (251.8 KB) - added by jfk 3 years ago.
my Ubuntu 10.10 crashed twice on WinXP host
VBox.log Download (166.9 KB) - added by Sacryn 3 years ago.
Installation of Windows XP (SP3 included)
VBox.png Download (4.5 KB) - added by Sacryn 3 years ago.
Screenshot of the "crash"
VBox.2.log Download (158.0 KB) - added by jeffdishman 3 years ago.

Change History

Changed 3 years ago by CaptainFlint

WinXP VM log (trying to install a new OS)

Changed 3 years ago by CaptainFlint

Win7 VM log (trying to boot OS from virtual hard disk)

Changed 3 years ago by wacher

WinXP host + WinXP guest

Changed 3 years ago by wacher

An other one occurence

Changed 3 years ago by jfk

my Ubuntu 10.10 crashed twice on WinXP host

comment:1 follow-up: ↓ 2 Changed 3 years ago by Sacryn

I get the same when trying to install Windows XP (with SP3). Crashes when the installer is about to format the harddrive. Attaching log/png.

Changed 3 years ago by Sacryn

Installation of Windows XP (SP3 included)

Changed 3 years ago by Sacryn

Screenshot of the "crash"

comment:2 in reply to: ↑ 1 Changed 3 years ago by Sacryn

Replying to Sacryn:

I get the same when trying to install Windows XP (with SP3). Crashes when the installer is about to format the harddrive. Attaching log/png.

Dont mind that the VDI/Guest is named "immutable". Setting the immutable flag was planed for later (after installation is completed).

comment:3 follow-ups: ↓ 5 ↓ 9 Changed 3 years ago by misha

We've fixed the problem that caused this behavior.
Please try  this test build with the fix to see if it solves the problem for you.

comment:4 Changed 3 years ago by alehandro

I"ve just tried the proposed test build and it fixes my issue reported in Ticket #9494 Thanks

comment:5 in reply to: ↑ 3 Changed 3 years ago by CaptainFlint

Replying to misha:

We've fixed the problem that caused this behavior.
Please try  this test build with the fix to see if it solves the problem for you.

Sorry for the late response, I was on a vacation.
With this test build my Windows machines work fine, so I confirm the fix. Thank you!

comment:6 Changed 3 years ago by lkraav

my Vista VM started throwing guru meditation after latest MS updates. Gentoo Linux host, on VB 4.1.0. is this latest trunk fix going to improve this for me as well? 4.1.2 doesn't have it yet right?

comment:7 Changed 3 years ago by jab

Hello, I have the same issue but with version 4.1.2.R73507. I(ve tried a vhd that work well on VPC and another that I can't try before but all with the same result. I've try to load Windows server 2003 (32 bits) and windows server 2008 (64bits). My host run under Windows 7 home edition.

comment:8 Changed 3 years ago by jeffdishman

So at what point does somebody answer this with working links. alehandro&lkraav ...links are dead!

Changed 3 years ago by jeffdishman

comment:9 in reply to: ↑ 3 Changed 3 years ago by jeffdishman

Replying to misha:

We've fixed the problem that caused this behavior.
Please try  this test build with the fix to see if it solves the problem for you.

DEADLINK

comment:10 follow-up: ↓ 14 Changed 3 years ago by frank

 Here is another test build.

comment:11 Changed 3 years ago by lkraav

i don't have a windows box to test on.

comment:12 follow-ups: ↓ 16 ↓ 17 Changed 3 years ago by frank

lkraav, your problem is different. Please open a new defect and attach the VBox.log file of such a crashing VM session.

comment:13 Changed 3 years ago by jab

Thanks. I've change somes parameters and now work.

comment:14 in reply to: ↑ 10 Changed 3 years ago by kradski

I can confirm + reliably reproduce the bug, and...

Replying to frank:

 Here is another test build.

I can confirm that this build fixes the problem.

Thanks a million =)

comment:15 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for testing. VBox 4.1.4 contains the fix.

comment:16 in reply to: ↑ 12 Changed 3 years ago by lkraav

Replying to frank:

lkraav, your problem is different. Please open a new defect and attach the VBox.log file of such a crashing VM session.

comment:17 in reply to: ↑ 12 Changed 3 years ago by lkraav

Replying to frank:

lkraav, your problem is different. Please open a new defect and attach the VBox.log file of such a crashing VM session.

Trac crashed on previous submit when I used Reply button.

4.1.4 has fixed my GURU MEDITATION issue as well. I re-enabled 2 CPU-s + virtualization options and Vista booted up with no issues.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use