VirtualBox

Ticket #9232 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

USB Device not recognized

Reported by: prairie Owned by:
Priority: major Component: USB
Version: VirtualBox 4.0.12 Keywords: Win7
Cc: Guest type: Windows
Host type: Mac OS X

Description

After updating to 4.0.10 and now to 4.0.12 and having the extension pack installed, I cannot get Win7 Home VM to accept USB Flash drives. Both were configured/added to the USB devices list in the VB manager. The message I get from Windows when I connect either of the USB Flash units is "USB Device not recognized". They had worked under release prior to 4.0.10.

Also, tried Ubuntu VM under 4.0.12 and it too will not mount USB flash device.

Attachments

VBox.log Download (78.1 KB) - added by prairie 3 years ago.
log file from attempting to connect USB flash device
VBox_4.1.log Download (83.6 KB) - added by prairie 3 years ago.
log file from 4.1 attempt to connect USB flash device

Change History

Changed 3 years ago by prairie

log file from attempting to connect USB flash device

comment:1 Changed 3 years ago by prairie

Just tried installing VB 4.1 and associated extension pack. Still have same error when attempting to connect USB flash drive.

This is quite a hindrance. I am going to try uninstalling 4.1 and go back to 4.08 when USB worked for me.

comment:2 Changed 3 years ago by prairie

Let me amend my note on 4.1. In my Ubuntu 11.04 VM, adding a USB device to the recognized list allows Ubuntu to mount said device.

It's my Win 7 Home VM that still gives a "USB Device not recognized error" even though the little USB indicator in the bottom panel correctly identifies the USB Flash device name that is connected to the USB port.

Changed 3 years ago by prairie

log file from 4.1 attempt to connect USB flash device

comment:3 Changed 3 years ago by prairie

When I changed from 2 cpus to 1 cpu for the VM and started my Win7 VM, Win7 recognized my USB flash drive right off. I've ejected and reconnected a few times and it looks like using 2 cpus is a no-go currently when wanting to mount USB devices. I confirmed that my Ubuntu VM only had 1 cpu specified so its working behavior is consistent.

Look for the topic  http://forums.virtualbox.org/viewtopic.php?f=8&t=37190&start=0 also.

Would like to run my VM with multiple cpus. That's how I unearthed this problem; it began after I bought a iMac (mid 2011) with quad cores and changed my VM cpu setting for Win 7.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

In that case this is a duplicate of #7462.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use