VirtualBox

Ticket #9220 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Linux Guest Hangs

Reported by: lin-unix Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

During the uptime of a VM my guest Linux OS hangs seemingly randomly. Most recently it happened while running Kubuntu 10.04. I do not have Guest Additions installed, which is when this issue happens most often.

I was installing packages at the time of the hang on the host. During the hang, I can move the mouse around within the VM, but not click anything. If I was clicking something, like a button, at the moment the VM hanged, the button remains depressed.

The network and hard drive icons in the status bar of the VM window, do not change - they are idle once the hang happens. Nonetheless the USB icon lights up when I move my mouse.

It's almost as if all I/O is suspended.

Attachments

Kubuntu-2011-07-17-20-02-19.log Download (81.2 KB) - added by lin-unix 3 years ago.
Log file
Capture.PNG Download (12.4 KB) - added by lin-unix 3 years ago.
VT 1

Change History

Changed 3 years ago by lin-unix

Log file

comment:1 Changed 3 years ago by michael

Can you still do VT switches on the guest (Host+Fn)? Then you might be able to find out a bit more about what is happening.

comment:2 Changed 3 years ago by lin-unix

I believe there could be an IO bottleneck somewhere - then again what do I know about Virtualbox? This bug is also a duplicate of multiple other bugs.

I can check the VT's and see what I can find, but this report can be marked as a duplicate.

BTW, this problem sill exists in 4.1

comment:3 Changed 3 years ago by lin-unix

Still happens in 4.1.2

Attached is a screenshot of VT1. It is useless.

Changed 3 years ago by lin-unix

VT 1

comment:4 Changed 2 years ago by frank

Please change the chipset type from ICH9 to PIIX3. Does that fix your problem?

comment:5 Changed 2 years ago by lin-unix

I'm not noticing this anymore. I guess this ticket can be closed.

comment:6 Changed 2 years ago by frank

  • Description modified (diff)

So this problem vanished just by updating to 4.1.8 or did you change VM setting?

comment:7 Changed 2 years ago by lin-unix

Sorry I should have been more specific. The problem vanished after an upgrade to 4.1

comment:8 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use