VirtualBox

Ticket #921 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Foresight Linux causes abort of Virtualbox

Reported by: bram85 Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.2 Keywords: foresight
Cc: Guest type: other
Host type: other

Description

On a Gentoo Linux host I try to install the Foresight Linux distribution with VirtualBox. This regularly fails when looking for installation sources. It should be reproducible just by pressing Enter and Next without making special settings. Note, sometimes it fails, sometimes it does not with exactly the same steps.

There is no disk/cdrom/network activity when the dialog pops (screenshot) up so its hard to find out on what part it is failing.

Attachments

VBox.log.1 Download (151.1 KB) - added by bram85 6 years ago.
Log file of the crashing instance with Foresight Linux
VBox.png.1 Download (70.7 KB) - added by bram85 6 years ago.
Screenshot at the point of crash during installation

Change History

Changed 6 years ago by bram85

Log file of the crashing instance with Foresight Linux

Changed 6 years ago by bram85

Screenshot at the point of crash during installation

comment:1 follow-up: ↓ 5 Changed 6 years ago by sandervl73

Can you try again with 1.5.4? If it still happens there, I'll have a look.

comment:2 Changed 6 years ago by sandervl73

  • Priority changed from major to critical

comment:3 Changed 6 years ago by snarkout

I was having the same problem when trying to install foresight 1.4.x as a guest, but was able to install foresight2 alpha w/o issue (in vbox 1.5.4 as well). Using the kernel options "pci=nommconf irqprobe all-generic-ide" at the initial install prompt I was able to get it successfully installed. FWIW, I've had similar issues when installing foresight 1.4.x on 945 and 965 chipset mobos with older flashes, so it's possible that this is a foresight 1.4.x default kernel option "bug" and not a virtualbox one. Hopefully this info is of at least some use :)

comment:4 Changed 6 years ago by snarkout

Oops, I should have added "acpi=off" to that list of options. I'm not sure all of those options were needed or not.

comment:5 in reply to: ↑ 1 Changed 6 years ago by bram85

Replying to sandervl73:

Can you try again with 1.5.4? If it still happens there, I'll have a look.

Alas, VirtualBox 1.5.4 didn't do it either. The same lockup as with VirtualBox 1.5.2 and reported above. I was able to get beyond that step only once, the rest of it resulted in an abort.

I forgot to mention that I'm trying with the ISO's of ForeSight Linux 1.4.1 x86 edition.

comment:6 Changed 6 years ago by bram85

Since I upgraded to 1.5.4 it sometimes aborts in the splash screen as well, stating "because your desktop should be freaking cool". Again, not always.

comment:7 Changed 6 years ago by snarkout

It appears I was incorrect when I said I could install foresight 1.4.x - I cannot reproduce the success with any combination of the kernel options I listed above, and the one "successful" install now drops into a stuck state as soon as I boot it. However, with the "acpi=off" option set, I get all the way through the install, and then bomb out at the very end of the install when foresight says that it's doing "postinstall configurations" or something similar to that. This happens with either text or graphical install mode, and with as much as 512 mb of RAM dedicated to the guest machine. I'm sorry for posting questionable info to the bug tracker - please let me know if there is anything I can provide to help debug this issue.

comment:8 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

If you can reproduce this behaviour with 1.6.x, then please reopen.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use