VirtualBox

Ticket #9207 (new defect)

Opened 3 years ago

Last modified 2 years ago

VirtualBox won't start with USB Sound card plugged in.

Reported by: ghoernersr Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: other
Host type: Windows

Description

I've read a few posts (I believe about older versions) where certain USB devices cause problems when connected to the system.

I have a USB Sound Card with a C-Media chipset. When connected, VBoxSvc.exe consumes an entire CPU core (running it @ 100%), and neither the interface nor virtual machines will start.

If I kill the VBoxSvc.exe, I get an error message about not being able to create the COM object (which I believe is as expected).

No log file (VBox.log) is generated/updated when this occurs. My VBox.log for the VM was last modified 5 days ago when I used it last. I added the sound card 2 days ago, and this is the first time I've tried starting a VM with it attached.

If I remove the sound card, everything works fine.

I would like to be able to start VMs without disconnecting my sound card, I will gladly attach any log files requested if a one exists elsewhere (I couldn't find any). Please let me know what I can do to help track down the problem.

Change History

comment:1 Changed 3 years ago by ghoernersr

I ran a few more tests, and it would seem that as long as VBoxSvc.exe is running before attaching the card, everything works fine.

comment:2 Changed 3 years ago by frank

You might want to test  VirtualBox 4.1 Beta 3. The next major version fixes a number of USB bugs on Windows hosts.

comment:3 Changed 3 years ago by davegreen

Latest version 4.1.0 -73009 with extension pack installed on a windows 7 host exhibits the exact same behavior as described.

I too would be very interested in this problem being resolved.

comment:4 Changed 2 years ago by gyurman

It also this problem is live in 4.1.8 r 5467 version. Pelase solve it fast, because we cant use well VB. I too would be very interested in this problem being resolved on W7SP1/64B.

comment:5 Changed 2 years ago by gyurman

This is: USB Multi-Channel Audio Device Generic USB Audio oem9.inf:C-Media.NTamd64:USB106X64:7.12.8.2140:usb\vid_0d8c&pid_0102&mi_00 {9d7debbc-c85d-11d1-9eb4-006008c3a19a} USB\VID_0D8C&PID_0102&REV_0010&MI_00 USB\VID_0D8C&PID_0102&MI_00

comment:6 Changed 2 years ago by steveVB

VB release 4.1.8 r75467 has the same problem with C-Media USB sound card. In my case the host is win 7 64 bit and the guest is win 7 32bit.

comment:7 Changed 2 years ago by steveVB

I downgraded to VB 4.0.4 and the sound card now works as before.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use