VirtualBox

Ticket #9197 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

Guest still thinks directory exists when it was deleted on the host

Reported by: yurivict Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Linux
Host type: other

Description (last modified by frank) (diff)

I created the directory within the shared folder in the guest. Then I deleted it on the host directly. After this an attempt to create the directory again from the guest fails with the error code: File exists. But 'ls -a' doesn't show the directory in the guest.

My host is FreeBSD (I know it's not officially supported), but I saw this on Linux host before too. Guest is Ubuntu 64bit.

Change History

comment:1 Changed 3 years ago by frank

  • Component changed from other to shared folders
  • Guest type changed from other to Linux

comment:2 Changed 3 years ago by Eldan

This is confirmed on a Windows 7 64-bit host with Fedora 15 64-bit guest. VirtualBox 4.1.0.

If you create a directory in the shared folder from the guest and delete it on the host, attempts to recreate the directory from the guest will fail until the shared folder is unmounted and remounted.

comment:3 Changed 2 years ago by gabipetrovay

Same behavior: Host: VB 4.0.12, Win 7 32-bit Guest: Ununtu Server 11.10

And I get:

gabriel@Cluj:~$ ll tmp ls: cannot access tmp: No such file or directory gabriel@Cluj:~$ mkdir tmp mkdir: cannot create directory `tmp': File exists

comment:4 follow-up: ↓ 5 Changed 2 years ago by hrehf

Same behavior:

  • Host: 4.1.8 on Win 7 x64
  • Client: Archlinux

Seems to occur a lot more after the 4.1.8 update; only a client reboot resets it to a usable state. Additionally, in the last week I noticed I sometimes cannot delete certain directories from the guest: rm -rf reports "foo is a directory", rm -r reports something else (but I cannot reproduce it right now). Lately also happens with files created by the client.

Also, time sync issues with the filesystem now require two fsck runs, while they were fixed after one before.

The Shared folder is on a raid.

comment:5 in reply to: ↑ 4 Changed 2 years ago by hrehf

Replying to hrehf:

  • rm -rf reports "foo is a directory"
  • rm -r reports "foo: no such file or directory"

Definitely happens with folder created from within the client

comment:6 Changed 2 years ago by manski

For now, you can "solve" this problem by restarting the guest additions:

/etc/init.d/virtualbox-guest-utils restart

comment:7 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

I think this is a duplicate of #9887. This affects only guest Linux kernels >= 2.6.38.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use