VirtualBox

Ticket #9194 (closed defect: fixed)

Opened 3 years ago

Last modified 5 months ago

VirtualBox core on loging after a long period of time => Fixed in SVN

Reported by: Gbillou Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

When I leave my computer on a virtual terminal, then switch back to my X server a long time later (don't know exactly but something like an hour), then login (because my workstation is locked) i find my VirtualBox session stopped and its state is "aborted". All other software are still running fine.

Change History

comment:1 Changed 3 years ago by misha

Did your guest have some mode switch (i.e. seamless<->windowed<->fullscreen) before the crash?

comment:2 Changed 3 years ago by Gbillou

Yes, i always run this vm in fullscreen mode but sometimes go to windowed mode to connect an usb key or else (i did hide the mini toolbar) Do you Wang me to try something?

comment:3 Changed 3 years ago by misha

So far I'm just trying to get the clue on how the VM process came to that broken state.. Could you specify in more detail steps you take to reproduce this, i.e.

  1. what guest you were running and were there any video or other sw using DDraw running in guest?
  2. were the VM running in a full screen mode when you switched off the X terminal
  3. did the VM crash already by the time you return back to X terminal? if not, were it still in the same mode (i.e. fullscreen?) ..just when you return? ..when it crashed?

comment:4 Changed 3 years ago by Gbillou

  1. I was running Windows Xp SP3 with guest addition 4.0.4 r70112. I did not try to run another guest. There were no directdraw application running. But i had run Acrobat Reader X, with a strange behavior when scrolling on pdf files. BTW it was not running while the vm crashed. Hmm, i'm not sure but maybe google chrome was running.. and so it might be using canvas or displaying a pdf file (not sure if it uses DDraw or not).
  2. yes
  3. yes, did crash already. I should have checked with VBoxManage from a VT if it did crash before going back to my X session. But yet i don't know. I'll try to check it next time i come back to my workstation and before going back to my X session.

I'm not able to reproduce it all time. I though so until today, as I leaved my computer on a vt, with as usal my win xp guest running on my X session. But when I came back let's say 1h30 later, the guest was still running (i found i "weird" thus it's the expected behavior :p)

comment:5 Changed 2 years ago by frank

  • Version changed from VirtualBox 4.0.10 to VirtualBox 4.1.6

We've got some more core dumps. We are trying to fix the problem but we still don't fully understand the problem.

comment:6 Changed 2 years ago by kerlerm

Problem persists with version 4.1.8 installed. Guests get aborted randomly.

comment:7 Changed 19 months ago by frank

  • Description modified (diff)

Still relevant with VBox 4.1.22?

comment:8 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:9 Changed 7 months ago by frank

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:10 Changed 7 months ago by frank

User qu3sti0n on IRC has the same problem with VBox 4.2.18 on Ubuntu 12.04 (Precise Pangolin). We already got the core dump.

comment:11 Changed 5 months ago by frank

  • Summary changed from VirtualBox core on loging after a long period of time to VirtualBox core on loging after a long period of time => Fixed in SVN

Finally we think we fixed this problem. The next 4.3.x maintenance release should contain the fix.

comment:12 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Should be finally fixed in 4.3.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use