VirtualBox

Ticket #9183 (closed defect: obsolete)

Opened 3 years ago

Last modified 2 months ago

Guest starts and freeze the VM and host systems

Reported by: upscope Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

  • Host: openSUSE 2.6.37.6-0.5-desktop
  • Guest: WIN XP SP2 (May be SP3)
  • VirtualBox-4.0-4.0.10_72479_openSUSE114-1.x86_64 (from VirtualBox web site)
  • VirtualBox Guest Additions Installed
  • Oracle_VM_VirtualBox_Extension_Pack-4.0.10-72436.vbox-extpack
  • KDE 4.6.5 (4.6.5) "release 8" (Platform Version)

Problem:

Virtual Manager shows four usb devices active:

  • XEROX Phaser 6120 [0100]
  • Cypress Semiconductor AT2+ Fast Bits [0001]
  • Western Digital My Book [0165]
  • CHESEN PS2 to USB Converter [0010]

If I have CHESEN device enable (Device sharing of Mouse, Monitor and keyboard between two system), XP Guest starts, hangs both Guest and Host on the VM desktop screen.
Must power off or reset system to restart and free up. This occured on 0.8 also, just left it disabled in Virtual Manager.

If it is disabled, the XP works but all usb devices come up disabled and require usb cables to be unplugged and replugged in to enable devices. Then all works fine until next start of VirtualBox.
This was not necessary of version 0.8.
CHESEN works fine switching between two Linux hosts on separate system.

Attachments

vbox-install.log Download (130.7 KB) - added by upscope 3 years ago.
Install Log
VirtualBox_test_Commands(bug#9183) Download (2.2 KB) - added by upscope 3 years ago.
Commands requested in comment#3

Change History

Changed 3 years ago by upscope

Install Log

comment:1 Changed 3 years ago by frank

  • Description modified (diff)

Next time please take a bit more care what you post and how you format it.

comment:2 Changed 3 years ago by frank

  • Summary changed from Guest starts and freeze the VM and host systems. O to Guest starts and freeze the VM and host systems

comment:3 Changed 3 years ago by michael

Could you please provide the output of the following commands with all four devices plugged in and no VM running?

$ VBoxManage list usbhost

and

$ ls -d /dev/vboxusb
$ ls -lR /dev/vboxusb

Changed 3 years ago by upscope

Commands requested in comment#3

comment:4 follow-up: ↓ 5 Changed 3 years ago by michael

Sorry I haven't had time to come back to this - answering the question you asked in the attached file, yes, please also try running

# ls -lR /dev/vboxusb

as root, (note that it is "l", not "I"). Have you tried VirtualBox 4.1? If so, was there any difference?

Regarding your CHESEN device, when you say it was enabled do you mean passed through to the VM?

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 3 years ago by upscope

Replying to michael:

Sorry I haven't had time to come back to this - answering the question you asked in the attached file, yes, please also try running

# ls -lR /dev/vboxusb

as root, (note that it is "l", not "I"). Have you tried VirtualBox 4.1? If so, was there any difference?

Regarding your CHESEN device, when you say it was enabled do you mean passed through to the VM?

Sorry I did not get back yet also. i will try the ls command and get info to you.

CHESEN - When I enable it in VirtualBox Manager under setting and then start the XP Guest. It goes to the MS XP desktop and freezes everything.

I loaded 4.1 and installed it last week but today is the first time I tried starting it. I get the following message:

Code


Failed to Access the USB subsystem

Could not load the Host USB Proxy Service (VERR_FILE_NOT_FOUND. The service might not be installed on the host computer.

Details:

Result Code: NS_ERROR_FAILURE (0x00004005) Component: Host Interface: IHost {dab4a2b8-c735-4f08-94fc-9bec84182e2f} Callee: IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}

I will check this also and if necessary try a comlete new install of VirtualBox.

Thanks for your response.

If you need more let me know. I will also download

comment:6 in reply to: ↑ 5 Changed 3 years ago by upscope

Replying to upscope:

Replying to michael:

Sorry I haven't had time to come back to this - answering the question you asked in the attached file, yes, please also try running

# ls -lR /dev/vboxusb

as root, (note that it is "l", not "I"). Have you tried VirtualBox 4.1? If so, was there any difference?

Regarding your CHESEN device, when you say it was enabled do you mean passed through to the VM?

Sorry I did not get back yet also. i will try the ls command and get info to you.

CHESEN - When I enable it in VirtualBox Manager under setting and then start the XP Guest. It goes to the MS XP desktop and freezes everything.

I loaded 4.1 and installed it last week but today is the first time I tried starting it. I get the following message:

Code


Failed to Access the USB subsystem

Could not load the Host USB Proxy Service (VERR_FILE_NOT_FOUND. The service might not be installed on the host computer.

Details:

Result Code: NS_ERROR_FAILURE (0x00004005) Component: Host Interface: IHost {dab4a2b8-c735-4f08-94fc-9bec84182e2f} Callee: IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}

I will check this also and if necessary try a comlete new install of VirtualBox.

Thanks for your response.

If you need more let me know. I will also download

Ran the ls command and here are the results.

Code


fj8u:~> ls -lR /dev/vboxusb /dev/vboxusb: total 0

Don't know what I should see.

Think the early error was caused by the fact I forgot to run the command: /etc/init.d/vboxdrv setup after install.

After checking that VirtualBox extensions and Guest additions were installed I tried starting my XP guest. It started, but all the usb devices were greyed out. They show as active in VirtualBox Manager.

I guess I'll uninstall and try reinstalling to see if it makes any difference.

comment:7 follow-up: ↓ 8 Changed 3 years ago by michael

If you see the same output for

# ls -lR /dev/vboxusb

when you run it as root then it sounds like the udev script (/etc/udev/rules.d/10-vboxdrv.rules) is not installed properly. If it is installed and you don't have any nodes, a reboot might make a difference. If the nodes are there as root then perhaps you have somehow lost membership of the vboxusers group? In any case,

$ ls -ld /dev/vboxusb

would be good to see.

comment:8 in reply to: ↑ 7 Changed 3 years ago by upscope

Replying to michael:

If you see the same output for

# ls -lR /dev/vboxusb

when you run it as root then it sounds like the udev script (/etc/udev/rules.d/10-vboxdrv.rules) is not installed properly. If it is installed and you don't have any nodes, a reboot might make a difference. If the nodes are there as root then perhaps you have somehow lost membership of the vboxusers group? In any case,

$ ls -ld /dev/vboxusb

would be good to see.

I just looked at /etc/udev/rules.d/ and there is no 10-vboxdrv.rules file. There are others like iscan , etc.

I installed from a download from the official website. I also checked the vboxusers group and I am a member..

Also here are results of the above commands with the vboxmanager started bit no the guest (Win XP).

As user:

llinux-fj8u:~> ls -lR /dev/vboxusb
/dev/vboxusb:
total 0

As Root:

linux-fj8u:~> sudo ls -lR /dev/vboxusb
root's password:
/dev/vboxusb:
total 0

As User:

linux-fj8u:~> ls -ld /dev/vboxusb
drwxr-x--- 2 root vboxusers 40 Aug 24 07:32 /dev/vboxusb

As Root:

linux-fj8u:~> sudo ls -ld /dev/vboxusb
drwxr-x--- 2 root vboxusers 40 Aug 24 07:32 /dev/vboxusb

Is there a script to execute for the rules or should I do a complete deinstall and reinstall?

Thanks for your reply.

Russ

comment:9 follow-up: ↓ 10 Changed 3 years ago by michael

Sounds like you are hitting the same issue as #9273. The contents of the udev rule are also at the top of that ticket, so you can create the rule file manually and see if that improves things (after a reboot).

comment:10 in reply to: ↑ 9 Changed 3 years ago by upscope

Replying to michael:

Sounds like you are hitting the same issue as #9273. The contents of the udev rule are also at the top of that ticket, so you can create the rule file manually and see if that improves things (after a reboot).

You were correct, there was no rule 10. I reinstalled VirtualBox with latest version from website. I now see my usb devices, but have not turned the Chesen box back on since the keyboard and mouse work fine without it.

Only problem now is when I first boot XP in Virtualbox, it says all usb devices are unavailable. But VirtualBox manager shows them active. If I power them up and down then XP sees them.

Is there a setting I'm missing? This used to sense the usb devices and start them on boot of XP. I will try and test the Chesen box later today ot tomorrow.

Thanks for your help.

comment:11 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use