VirtualBox

Ticket #9143 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

EFI Panic when guest memory > 2GB

Reported by: evik Owned by:
Priority: major Component: EFI
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: other
Host type: Windows

Description

If EFI is enabled and the guest memory is > 2GB then there is an Unexpected trap and EFI Panic even before the splash screen, the VM crashes. I have this problem with 4.0.10 (does not know if 4.0.8 is affected, updated before creating the VM) on a Windows 7 64bit host. The guest OS is indifferent since the VM does not get to the point to touch the CD.

Attachments

VBox.log Download (53.6 KB) - added by evik 3 years ago.
VBox-OSX.log Download (45.6 KB) - added by evik 3 years ago.
VBox.log with the same EFI panic on Apple hardware

Change History

Changed 3 years ago by evik

comment:1 Changed 3 years ago by evik

I found this on the forums: In the 3.2.6 Beta, 64 bit works; More than 2GB RAM does not unless Video Memory ≤ 64MB. And indeed with video memory set to ≤ 64MB I was able to boot with more then 2GB of guest memory. (guest type is set to OS X tried 64bit and 32bit, produces the same results)

comment:2 Changed 3 years ago by Perryg

Currently OS X is not supported unless it is installed on Apple hardware.

comment:3 Changed 3 years ago by evik

Please read the whole bug report and do not single out the OS X part. It is an EFI panic issue if the memory is set to more then 2GB and video memory is greater then 64MB. I wrote the guest OS type only to indicate that it happens with 32bit and 64bit guest also (I do not think if it changes anything, I saw on forums that depending on the guest type the EFI has 32bit or 64bit code.) So the problem is NOT related to guest type, the boot hangs even before EFI initialization finished and BEFORE any media is touched (not even the install disk...).

To get around those who can't read through the whole bug report and just jump on individual parts without the context I repeated the problem on a MacBook Pro runningOS X 10.6 Snow Leopard (up to date to the latest patch level) with VirtualBox 4.0.10. I attached the log file as VBox-OSX.log.

Changed 3 years ago by evik

VBox.log with the same EFI panic on Apple hardware

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7002.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use