VirtualBox

Ticket #9142 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

Bluescreen on starting VirtualBox 4.1 BETA 1

Reported by: confusedsushi Owned by:
Priority: major Component: other
Version: Keywords:
Cc: Guest type: other
Host type: Windows

Description

Hello

I just installed the new VirtualBox 4.1 BETA 1. Unfortunately it is not usable at all. Every time I start VirtualBox I get a BlueScreen. I do not start any virtual machine, just the main gui. It is always the same. Same instruction referencing same memory. Seems to happen while opening the USB driver. I am using Windows 7 SP 1 64 bit as host. Here some Information WinDbg gives me.

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: SRV*C:\Symbols*http://msdl.microsoft.com/download/symbols;d:\clib
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (6 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17592.amd64fre.win7sp1_gdr.110408-1631
Machine Name:
Kernel base = 0xfffff800`02e0a000 PsLoadedModuleList = 0xfffff800`0304f650
Debug session time: Fri Jul  1 21:19:21.095 2011 (UTC + 2:00)
System Uptime: 0 days 0:13:11.874
Loading Kernel Symbols
...............................................................
................................................................
.............................................
Loading User Symbols
PEB is paged out (Peb.Ldr = 000007ff`fffd8018).  Type ".hh dbgerr001" for details
Loading unloaded module list
.........
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck D1, {70, 2, 1, fffff880095746fa}

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for VBoxUSBMon.sys - 
Probably caused by : VBoxUSBMon.sys ( VBoxUSBMon+46fa )

Followup: MachineOwner
---------

4: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 0000000000000070, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff880095746fa, address which referenced memory

Debugging Details:
------------------


WRITE_ADDRESS:  0000000000000070 

CURRENT_IRQL:  2

FAULTING_IP: 
VBoxUSBMon+46fa
fffff880`095746fa 488744d170      xchg    rax,qword ptr [rcx+rdx*8+70h]

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0xD1

PROCESS_NAME:  VBoxSVC.exe

TRAP_FRAME:  fffff8800cf53500 -- (.trap 0xfffff8800cf53500)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff880095746fa rsp=fffff8800cf53690 rbp=fffffa80080ce070
 r8=fffffa8008086680  r9=0000000000000000 r10=fffffa8006c4caa0
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
VBoxUSBMon+0x46fa:
fffff880`095746fa 488744d170      xchg    rax,qword ptr [rcx+rdx*8+70h] ds:001c:0070=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002e892a9 to fffff80002e89d00

STACK_TEXT:  
fffff880`0cf533b8 fffff800`02e892a9 : 00000000`0000000a 00000000`00000070 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`0cf533c0 fffff800`02e87f20 : fffffa80`07dd07b0 fffff880`0cf53c20 00000000`0000000f fffff880`0958b908 : nt!KiBugCheckDispatch+0x69
fffff880`0cf53500 fffff880`095746fa : fffff880`0cf53738 fffffa80`07e12d30 fffffa80`07e12d30 fffff880`0958b908 : nt!KiPageFault+0x260
fffff880`0cf53690 fffff880`09571eb9 : 00000000`00000000 fffffa80`07dd07b0 00000000`00000000 00000000`00000700 : VBoxUSBMon+0x46fa
fffff880`0cf536c0 fffff880`095721d6 : 00000000`00000000 fffffa80`07f98800 fffffa80`07c91c70 00000000`00000000 : VBoxUSBMon+0x1eb9
fffff880`0cf53700 fffff800`03187625 : fffffa80`07f98800 00000000`00000000 00000000`00000025 fffffa80`0a0a77c8 : VBoxUSBMon+0x21d6
fffff880`0cf53730 fffff800`03183ec8 : fffffa80`0a0d76d0 00000000`00000000 fffffa80`0a0a7610 00000000`00000001 : nt!IopParseDevice+0x5a5
fffff880`0cf538c0 fffff800`031850e6 : 00000000`00000000 fffffa80`0a0a7610 fffff680`00c00220 fffffa80`06c537b0 : nt!ObpLookupObjectName+0x588
fffff880`0cf539b0 fffff800`031869ec : fffffa80`07e17b98 00000000`00000000 fffffa80`0a137901 ffffffff`ffffffff : nt!ObOpenObjectByName+0x306
fffff880`0cf53a80 fffff800`03191608 : 00000000`02c7d1c8 fffff880`c0100080 00000000`02c7d218 00000000`02c7d1d8 : nt!IopCreateFile+0x2bc
fffff880`0cf53b20 fffff800`02e88f93 : fffffa80`0a137990 0000007f`ffffffff fffff880`0cf53bc8 00000980`00000000 : nt!NtCreateFile+0x78
fffff880`0cf53bb0 00000000`77c3186a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`02c7d148 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77c3186a


STACK_COMMAND:  kb

FOLLOWUP_IP: 
VBoxUSBMon+46fa
fffff880`095746fa 488744d170      xchg    rax,qword ptr [rcx+rdx*8+70h]

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  VBoxUSBMon+46fa

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: VBoxUSBMon

IMAGE_NAME:  VBoxUSBMon.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4e0cb21d

FAILURE_BUCKET_ID:  X64_0xD1_VBoxUSBMon+46fa

BUCKET_ID:  X64_0xD1_VBoxUSBMon+46fa

Followup: MachineOwner
---------

4: kd> lmvm VBoxUSBMon
start             end                 module name
fffff880`09570000 fffff880`09596000   VBoxUSBMon   (export symbols)       VBoxUSBMon.sys
    Loaded symbol image file: VBoxUSBMon.sys
    Image path: \SystemRoot\system32\DRIVERS\VBoxUSBMon.sys
    Image name: VBoxUSBMon.sys
    Timestamp:        Thu Jun 30 19:27:57 2011 (4E0CB21D)
    CheckSum:         0002E5C4
    ImageSize:        00026000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4

4: kd> .trap 0xfffff8800cf53500
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff880095746fa rsp=fffff8800cf53690 rbp=fffffa80080ce070
 r8=fffffa8008086680  r9=0000000000000000 r10=fffffa8006c4caa0
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
VBoxUSBMon+0x46fa:
fffff880`095746fa 488744d170      xchg    rax,qword ptr [rcx+rdx*8+70h] ds:001c:0070=????????????????

Hope this helps.

Attachments

070211-17971-01.dmp Download (260.0 KB) - added by confusedsushi 3 years ago.

Change History

comment:1 Changed 3 years ago by Technologov

Invalid.

Use forum for the BETA version:  http://forums.virtualbox.org/viewforum.php?f=15

-Technologov

comment:2 Changed 3 years ago by misha

please attach a minidump for the crash here.

comment:3 Changed 3 years ago by confusedsushi

There is already a forum thread for this bug. Sorry didn't found the forum in the first place.

Changed 3 years ago by confusedsushi

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use