VirtualBox

Ticket #9137 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

Gnome 3 display problems, VB 4.0.10 under Mac OS 10.5.8

Reported by: JustinLHeuser Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by frank) (diff)

The following was aired in the forum ( http://forums.virtualbox.org/viewtopic.php?f=8&t=42670) and perryg recommended I report this as a regression. This may be a Guest Additions problem, but I have not made that assumption in assigning the component in which the problem appears.

Using VirtualBox 4.0.8 running under Mac OS 10.5.8 Leopard, I was able to run Ubuntu 11.04 Unity. Fedora 15 only worked in classic. But when I upgraded to VB 4.0.10, neither Ubuntu 11.04 nor Fedora 15 worked. I was able to restore functionality by removing the 4.0.10 Guest Additions, running the 4.0.10 uninstaller, and then re-installing 4.0.8.

Fedora 15 with Guest Additions 4.0.10 looked fine until I logged in in classic mode. Once I did that, it just displayed large white rectangles. Sometimes the whole virtual display large. When it wasn't the whole display, the Fedora default wallpaper was behind the white rectangles. At least, that's what I remember -- there was considerable thrashing around with this issue, as you can imagine.

Ubuntu 11.04 with Guest Additions 4.0.10 also looked fine until I logged in. Once I did that under Unity, it displayed the default wallpaper. Occasionally my own wallpaper and some of the windows would flicker into view, with the dock (or whatever they call it) on the left and the menu at the top as just gray rectangles. This flickering-in-and-out did not seem to correlate to anything I was doing with the VM - it happened even when the VM did not have focus. When the default wallpaper was on display, I could see my own wallpaper and windows (complete with gray blobs) displayed very small in the lower left-hand corner of the virtual display. In this context, "very small" means about the size of the image displayed in the OS X dock icon.

Now, 10.5.8 Leopard is a release behind -- about to be two when Lion comes out. Does Oracle not support the combination of Gnome 3 on VirtualBox under Mac OS 10.5? Or do the symptoms suggest something I might have done wrong? Or is my explanation completely unclear?

Oh - Fedora 14 and Ubuntu 10.04 work for me without problems under both 4.0.8 and 4.0.10. Both Fedora 14 and Fedora 15 were clean installs. The Ubuntu 11.04 is an upgrade from the 10.04 (via 10.10). Both Fedora 15 and Ubuntu 11.04 had 3D acceleration turned on in the VB control panel. The Ubuntu 11.04 had 32 meg of video memory assigned in the VB control panel, the Fedora 15 had 128 meg, per recommendations in the fora (forums?) of the respective operating systems. The hardware is a mid-2007 20-inch iMac, 2GHz, 2Gb memory, and is actually about 4.5 years old.

Attachments

xsession-errors-classic-with-no-guest-additions.log Download (3.1 KB) - added by JustinLHeuser 3 years ago.
.xsession-errors with no guest additions installed. Usable.
xsession-errors-classic-with-4.0.10-guest-additions.log Download (2.3 KB) - added by JustinLHeuser 3 years ago.
.xsession-errors logged in in Classic mode with Guest Additions 4.0.10. Usable.
xsession-errors-unity-with-4.0.8-guest-additions.log Download (6.4 KB) - added by JustinLHeuser 3 years ago.
.xsession-errors in Unity with Guest Additions 4.0.8 installed. Not usable.
xsession-errors-unity-with-4.0.10-guest-additions.log Download (7.0 KB) - added by JustinLHeuser 3 years ago.
.xsession-errors in Unity with Guest Additions 4.0.10 installed. Not usable.
xsession-errors-4.0.12-classic-with-no-guest-additions.log Download (2.3 KB) - added by JustinLHeuser 3 years ago.
VirtualBox 4.0.12 with no guest additions, displaying Ubuntu Classic
xsession-errors-4.0.12-unity-with-4.0.8-guest-additions.log Download (6.0 KB) - added by JustinLHeuser 3 years ago.
VirtualBox 4.0.12 with Guest Additions 4.0.8, trying to display Ubuntu Unity
xsession-errors-4.0.12-unity-with-4.0.12-guest-additions.log Download (7.2 KB) - added by JustinLHeuser 3 years ago.
VirtualBox 4.0.12 with Guest Additions 4.0.12, trying to display Ubuntu Unity

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by twasson

I'm seeing slightly different, but likely related, graphical issues with Ubuntu 11.04 under VirtualBox 4.0.10 on a Mac host. In my scenario, everything was working well in 4.0.8, but upon upgrading to 4.0.10 the GNOME Unity interface in Ubuntu 11.04 only updates the display after a subsequent input action has taken place. It's difficult to describe, but, for example, if I click the Ubuntu button in the upper-left corner to bring up a menu of shortcuts, I don't see the screen update to render the menu until I've subsequently clicked elsewhere, at which time I see the menu had been drawn but now the focus is off of it and in reality the menu is no longer displayed. I'm still seeing it displayed, though; it's almost like the video buffer isn't synchronizing immediately but is doing so after some kind of flush that only happens upon further input actions. It's very odd, it renders Unity unusable, and it didn't happen before 4.0.10.

One other thing: if I use Kubuntu 11.04 (i.e., Ubuntu with KDE instead of GNOME), it works completely fine. It's also fine in "classic" mode in Ubuntu 11.04 with GNOME. So this is probably some weird issue related to how Unity is using the display.

Turning off 3D acceleration forces GNOME into classic mode, so that doesn't fix it. Nor does increasing video memory. I'm not sure what else to try, but I mostly just wanted to give a "me too."

Changed 3 years ago by JustinLHeuser

.xsession-errors with no guest additions installed. Usable.

Changed 3 years ago by JustinLHeuser

.xsession-errors logged in in Classic mode with Guest Additions 4.0.10. Usable.

Changed 3 years ago by JustinLHeuser

.xsession-errors in Unity with Guest Additions 4.0.8 installed. Not usable.

Changed 3 years ago by JustinLHeuser

.xsession-errors in Unity with Guest Additions 4.0.10 installed. Not usable.

comment:2 in reply to: ↑ 1 Changed 3 years ago by JustinLHeuser

After thinking a little, I had another crack at upgrading to 4.0.10, with no better luck. Before upgrading again I confirmed the MD5 hash on the downloaded .dmg file. Yes, it was correct.

After upgrading, I started up an Ubuntu 11.4 virtual machine and tried various combinations of guest additions and login types. It looks like Classic is fine, however you get there, but Unity is unusable. I have attached .xsession-errors files from various trials. I did not attach a file from a session with Guest Additions 4.0.10, Unity log-in, but 3D acceleration turned off. This fell back to Classic just as you would expect, and was perfectly usable.

If I can provide any other logs or any other information, I will be glad to do so.

Changed 3 years ago by JustinLHeuser

VirtualBox 4.0.12 with no guest additions, displaying Ubuntu Classic

Changed 3 years ago by JustinLHeuser

VirtualBox 4.0.12 with Guest Additions 4.0.8, trying to display Ubuntu Unity

Changed 3 years ago by JustinLHeuser

VirtualBox 4.0.12 with Guest Additions 4.0.12, trying to display Ubuntu Unity

comment:3 Changed 3 years ago by JustinLHeuser

No joy under 4.0.12 either. Symptoms pretty much the same as 4.0.10. Logs attached again.

Is there anything I can do to assist?

comment:4 Changed 3 years ago by closethipster

I've been seeing the same behavior since 4.0.10. With Fedora 15, fallback mode works fine but in GNOME shell the screen doesn't refresh without a subsequent input. With Ubuntu 11.04, classic mode works fine but in Unity the screen doesn't refresh without a subsequent input.

I'm on Mac OS X 10.6.7. Core 2 Duo iMac. ATI Radeon HD 4670 w/ 256 MB VRAM. If there is any additional information I can provide, please let me know.

comment:5 Changed 3 years ago by closethipster

No change with 4.1.0.

comment:6 Changed 3 years ago by JustinLHeuser

I confirm no change under 4.1.0. I'm not going to the trouble of collecting logs, though, until I see evidence that someone is reading them. :-(.

I have more severe symptoms -- the screen does not reliably refresh under Unity even with input. I get black rectangles where content is supposed to be, or just Ubuntu's default wallpaper (which I have changed), with my whole desktop (black rectangles and all) crammed into the bottom left hand corner, about the same size as the display in the icon.

And under 4.1.0, the old control/alt/f3 trick does not get you a very usable console. You can type, and it responds, but the display is screwed up, so you are typing blind. Fortunately Classic still works.

At some point, I'm going to just give up and freeze at 4.0.8.

comment:7 Changed 3 years ago by closethipster

No change under 4.1.2. Ubuntu/Unity and Fedora/GNOME3 continue to be unusable.

comment:8 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use