VirtualBox

Ticket #9136 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

Nestopia runs too fast -> duplicate of #10080

Reported by: twipley Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Nestopia v1.40 on XP guest runs about five times faster that NES games are supposed to be running at. Sound is also speeded up. Host is Ubuntu v11.04.

Attachments

entert-2011-06-30-20-13-57.log Download (56.9 KB) - added by twipley 3 years ago.

Change History

Changed 3 years ago by twipley

comment:1 Changed 3 years ago by twipley

Note: happens in v4.1 Beta1, too.

comment:2 Changed 3 years ago by twipley

Any idea concerning the cause of this issue? It is a strange one.

comment:3 Changed 3 years ago by twipley

It has come to me that the cause might be lying in the "synchronize to refresh rate" option that has been set in concerning various console emulators. More precisely, I think that vertical synchronization (vsync) makes it so that the game runs to 300+ fps while the emulator "thinks" it is running at the normal speed. Makes any sense whatsoever?

comment:4 in reply to: ↑ description Changed 2 years ago by twipley

I have opened a clearer bug ticket for the same issue: https://www.virtualbox.org/ticket/10080

(This one may therefore at will be closed.)

comment:5 Changed 2 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Nestopia runs too fast to Nestopia runs too fast -> duplicate of #10080
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use