VirtualBox

Ticket #9132 (closed defect: fixed)

Opened 3 years ago

Last modified 3 months ago

Switching from 32-bit to 64-bit OS Type/version doesn't work

Reported by: srondeau Owned by:
Priority: minor Component: other
Version: VirtualBox 4.0.10 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

We inadvertently chose the default "Windows 7" (32-bit) OS type when defining a VM and then installing from a 64-bit Windows 7 .iso file. Windows 7 provided an error message, and we eventually figured out it was because we were running a 32-bit VM for a 64-bit OS. So, in the VirtualBox GUI we switched the Version (os type) to "Windows 7 (64 bit)", and started the VM again with the same .iso file, and the same error message appeared when Windows 7 tried to install.

We then defined another VM using "Windows 7 (64 bit)", used the same 64-bit Windows 7 .iso file to start the installation, and it worked fine. Consequently, I think something is wrong when switching between OS types, at least for "Windows 7" os type and "Windows 7 (64 bit)" -- that it doesn't set up the 64-bit environment properly.

Change History

comment:1 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

This works now (VBox 4.3.6). The 64-bit capability can also be enabled by 'VBoxManage modifyvm VM_NAME --longmode on'.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use