VirtualBox

Ticket #913 (new defect)

Opened 6 years ago

Last modified 4 years ago

iTunes can't burn CDs

Reported by: elanthis Owned by:
Priority: major Component: DVD
Version: VirtualBox 1.5.2 Keywords: passthrough
Cc: Guest type: other
Host type: other

Description

iTunes (latest version as of today) on a Windows XP SP2 guest (all available critical and optional updates, as of today) on an Ubuntu Hardy Heron 8.04 dev machine, cannot burn CDs. iTunes simply says something like "Can't find burner or burning software."

Passthrough and all that is enabled. Reading CDs works just fine. Windows and iTunes are detecting the blank CD-R media.

The VBox.log is filled with a ton of errors identical (except the timestamp) to the following:

00:01:52.334 PIIX3 ATA: LUN#2: CD-ROM passthrough command (0x28) error 5 VERR_DEV_IO_ERROR

Attachments

VBox.log Download (53.2 KB) - added by elanthis 6 years ago.
vbox log file
VBox.2.log Download (31.7 KB) - added by firecat53 6 years ago.
Vbox log file

Change History

Changed 6 years ago by elanthis

vbox log file

comment:1 Changed 6 years ago by Technologov

Duplicate of bug #903.

-Technologov

comment:2 Changed 6 years ago by klaus

This might technically be a duplicate, but as long as #903 contains less information (no log files) I'll work with this one. The log file attached clearly shows that passthrough is successfully enabled, but each and every command which is attempted to be sent to the host drive fails.

And the error code is exactly the one I get if I try it out here without a medium in the drive. Is it possible that you put the CD/DVD in the wrong drive? Or (much less likely) do you have insufficient permission on /dev/hda? The user running VBox must have read/write permission to the device representing the CD/DVD recorder.

comment:3 Changed 6 years ago by firecat53

I also have this issue. Running virtualbox 1.5.6 (passthrough enabled). WinXP home guest, Ubuntu 7.10 amd64 host. Installed Infra Recorder and tried to blank a cd-rw. Had to switch to a virtual terminal and reboot the computer. The light just started blinking on the cd-drive, I could move the mouse in XP and Ubuntu, but no keyboard input other than the ctrl-alt F1 was accepted. I attached the vbox.log above, but the errors were repeats of:

00:07:37.979 PIIX3 ATA: LUN#2: CD-ROM passthrough command (0x5a) error 5 VERR_DEV_IO_ERROR

The cd drive shows up correctly named as the dvd-ram drive, but under device properties, it just shows it as a vbox-cd rom or some such. Tried uninstalling the driver in XP, but it just reinstalled the same one again.

Let me know if I can provide additional information. Thanks, Scott

Changed 6 years ago by firecat53

Vbox log file

comment:4 Changed 6 years ago by frank

  • Keywords passthrough added
  • Component changed from other to DVD
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use