VirtualBox

Ticket #9115 (closed defect: worksforme)

Opened 3 years ago

Last modified 17 months ago

VB fails to import an appliance it created with no valid error message

Reported by: Baylink Owned by:
Priority: critical Component: OVF
Version: VirtualBox 4.0.10 Keywords: appliance import fail
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

All work done with the VirtualBox GUI:

  • 1) Create a new VM and VDI, install CentOS5.6 - works ok
  • 2) Export as centos56base.ova - ok
  • 3) Import centos56base.ova to new VM, changing basename of the appliance and associated VDI to centos56zimbra - ok
  • 4) Start VM - ok
  • 5) Install Zimbra ZCS 7 - ok
  • 6) Shut down centos56zimbra
  • 7) Import centos56base.ova to new VM, changing basename of the appliance and associated VDI to centos56lamp1 - fail

The second import fails with the error dialog

"Failed to import appliance: /root/Documents/centos56base.ova."

after a several minute thermometer delay (during which the dialog shows 1/2 and 2/2), whether I turn off the Sound and USB controllers I'm not going to use, or not. If I make a second attempt without closing the Import dialog, it fails immediately. If I close the dialog first, then loop back to 7.

Note that this .ova *has* imported cleanly, back in step 3; same file; no changes to anything I can think of.

The only change that was made to the Host phys was the doubling of RAM from 8GB to 16GB; same kernel:

Linux host1 2.6.34.8-0.2-pae #1 SMP 2011-04-06 18:11:26 +0200 i686 athlon i386 GNU/Linux

Host OS SuSE 11.3/64, Vbox 4.0.8 from repo, guest OS CentOS 5.6/32.

klaus-vb on IRC suggested I set up for coredumps and see if I got one; I don't.

.ovf attached, as suggested.

Change History

comment:1 Changed 3 years ago by Baylink

Since Trac is throwing a traceback when I try to attach the .ovf file as instructed, that file is here:

 http://pastebin.com/S3LN0v3L

comment:2 Changed 3 years ago by poetzsch

I tried this ovf and it works without problems. Also I do not understand what you described as "thermometer delay" and "shows 1/2 and 2/2". Could you import the ovf again after shutting down VBox and wait at least one minute?

comment:3 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use