Ticket #9098 (closed defect: worksforme) — at Version 5

Opened 7 years ago

Last modified 7 years ago

No connection from host to guest using Host-only network adaptor

Reported by: ndastur Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

Using a linux host (CentOS 5.6) and a linux guest (tried ubuntu server 11 and CentOS 5.6) the host-only adaptor fails to allow connection from host to guest.

I had originally posted to the forums about it and there is a lot more detail about the problem there.

Change History

comment:1 Changed 7 years ago by ndastur

Note: that on my OSX guest if I bring the same appliance over, the networking works as described in the manual so I suspect this is a Linux host bug.

comment:2 Changed 7 years ago by ndastur

I thought it might be useful to show the OSX routing table. I did an appliance export on my CentOS machine, copied to my OSX machine and then import. No settings were changed It seems that on OSX I have a route set up to my VM on This route is not correctly setup on my CentOS box.

{{{netstat -nr Routing tables

Internet: Destination Gateway Flags Refs Use Netif Expire default UGSc 28 0 en1 127 UCS 0 0 lo0 UH 4 164801 lo0 169.254 link#5 UCS 0 0 en1 192.168.1 link#5 UCS 4 0 en1 0:xx:xx:xx:xx:xx UHLWI 28 17 en1 1179 ff:ff:ff:ff:ff:ff UHLWbI 0 3 en1 192.168.56 link#7 UC 3 0 vboxnet a:0:27:0:0:0 UHLWI 0 3 lo0 2:0:2:0:aa:2 UHLWI 0 0 vboxnet 1029 link#7 UHLWbI 1 40 vboxnet}}}

Changed 7 years ago by ndastur

Log file from CentOS VM

Changed 7 years ago by ndastur

Log file from OSX, using exported then imported VM

comment:3 Changed 7 years ago by ndastur

Just tried starting Headless on OSX and works fine. So not a difference because of start up method

comment:4 Changed 7 years ago by aleksey

Please, post the output of ifconfig from CentOS host after you've started VM. In 4.0.x versions of VirtualBox vboxnet0 inferface gets created when vboxnetadp kernel module is loaded, but it has no IP address configured initially. The interface is assigned the address as soon as any VM using this interface is started.

comment:5 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use