VirtualBox

Ticket #9097 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Ubuntu hangs in VB 4.0.8 when CPU > 1

Reported by: warden Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

The problem is very widely described  here.

VM guest of Ubuntu (fully upgraded), running GNome, is randomly hanging. At the very beginning, it looks like a "silly window syndrome". I am able to switch between windows, but I when I try to close any applications, I think they are closed, but the screen GUI stays there. Reboot is impossible (I mean via Ubuntu options, ctrl+r works fine).

The problem appears when I set CPU cores to >1. My host machine is running Win7 64-bit, Intel Core I5, M480, 2.67GHz, 6.00 GB RAM. The guest system is 32-bit ubuntu, 2GB RAM, guest tools installed.

Attachments

Ubuntu-2011-06-22-16-51-18.log Download (51.7 KB) - added by warden 3 years ago.
Log
dmesg Download (34.6 KB) - added by warden 3 years ago.
dmesg

Change History

Changed 3 years ago by warden

Log

comment:1 Changed 3 years ago by frank

Could you retry with VBox 4.0.10? There were some timer fixes for SMP guests. In case it still fails, please add the output of 'dmesg' from the guest to this ticket.

comment:2 Changed 3 years ago by warden

hm, my VBox 4.0.8 is saying that I have the newest version installed. Bug in the auto-update mechanism? i'm downloading now from the webpage...

comment:3 Changed 3 years ago by frank

No bug but excepted behavior. The update notifier has some delay.

Changed 3 years ago by warden

dmesg

comment:4 Changed 3 years ago by warden

Unfortunately, it hanged after 15 minutes of doing nothing, just after start of Ubuntu. Dmesg attached.

comment:5 Changed 3 years ago by warden

If you have any news or requests to test on that issue, I'd be glad to help because now with only one CPU it is very slow...

comment:6 Changed 3 years ago by frank

Please update to VBox 4.0.10. There were some timer fixes in this release which could affect your problem. Also see #7619.

comment:7 Changed 3 years ago by warden

I have updated to 4.0.10 just as you have asked in the first comment. The dmesg and other comments are after upgrade. I will try the nolapic_timer though.

comment:8 Changed 3 years ago by frank

I'm sorry, I was too quick reading your comment.

comment:9 Changed 3 years ago by frank

I think I know the root of the problem in your case. You have the ICH9 chipset enabled which also means that the HPET is enabled. In that case, the HPET is used as clock source. In VBox 4.0.10 there was a timer fix for the ACPI timer but not for the HPET timer. So adding clocksource=acpi_pm to your guest kernel might resolve your problem. The proper fix for the HPET timer will be in the upcoming 4.1 release.

comment:10 Changed 3 years ago by warden

you are right, I think that fixed the problem! it would be really nice though to show a warning box or have a FAQ tab with infos helpful (that changes according to the current settings of the VM guest) with such info because that was very frustrating and finding info about it is not so easy as you can see. Thanks!

comment:11 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Let's close this bug. VBox 4.1 should fix the HPET timer as well.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use