VirtualBox

Ticket #9094 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

'Failed to access the USB subsystem' error, when accessing settings for an image and no USB devices

Reported by: bikehead Owned by:
Priority: major Component: USB
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

My windows7 guest is running pretty well on my Fedora 15 host, but I cannot get Vbox to access any of my USB devices. This F15 is a fresh install as is the VirtualBox rpm and the Windows 7 guest.

At guest start everything looks normal with no error messages. However, when I use machine->devices->USB I don't see any attached USB devices. When I access "settings" for the machine I get the following pop up:

Failed to access the USB subsystem. Could not load the Host USB Proxy Service (VERR_FILE_NOT_FOUND). The service might not be installed on the host computer.

followed by:

Result Code: NS_ERROR_FAILURE (0x00004005) Component:

Host

Interface:

IHost {35b004f4-7806-4009-bfa8-d1308adba7e5}

Callee:

IMachine {662c175e-a69d-40b8-a77a-1d719d0ab062}

Change History

comment:1 Changed 3 years ago by michael

Is your user a member of the "vboxusers" group?

comment:2 Changed 3 years ago by bikehead

yes.

comment:3 Changed 3 years ago by bikehead

I take that back: I was in the group in /etc/group, but possibly not in the shadow files. When I used system-config-user and added it the warning message went away.

Sorry making you deal with user error.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for that information.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use