VirtualBox

Ticket #9081 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

After upgraded to v4.0.8 from v4.0.6, windows 7 wouldn't boot

Reported by: frankin Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

After upgrading to v4.0.8, Windows 7 wouldn't but. I restore an older snapshot and still wouldn't boot. I then downgraded it back to v4.0.6 and the machine restored, but after reboot, it went into chkdsk and found disk error, once error was fixed, the Windows boot past the logo and then mouse cursor showed up and the machine stay in this state and doesn't proceed.

Change History

comment:1 Changed 3 years ago by frank

Please attach a VBox.log file of a VM session where you tried to boot your guest.

comment:2 Changed 3 years ago by lanceep

We have four different systems running XP on a VHD inside VirtualBox and all of them failed within a day of each other with disk errors. We thought that it might be related to an XP update, but we found the same error on a system that hadn't even run VirtualBox for several weeks and didn't have any update to VirtualBox or XP. None of the VirtualBox systems had been updated for serveral weeks and had been working fine. I tried converting the VHD to a VDI and got the same error. When I used Virtual PC to run the VHD it came up with no problems.

comment:3 Changed 3 years ago by frank

We just found a bug in the VHD code which could be responsible for such behavior. The next maintenance release (4.1.4) will contain the fix so I would appreciate if you could test it. I could even provide you a test build if desired.

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use