VirtualBox

Ticket #9079 (new defect)

Opened 3 years ago

VMs lose connectivity (VRDP, ssh and some times even VBoxManager)

Reported by: sebastians Owned by:
Priority: major Component: VM control
Version: VirtualBox 3.2.12 Keywords: lost connectivity, stuck vm
Cc: Guest type: Linux
Host type: Linux

Description

Environment:
Host: VirtualBox 3.2.12r68302, on ProLiant BL490c G6 (CPU 1 Six-Core Intel Xeon, 2667 MHz, CPU 2 Six-Core Intel Xeon, 2667 MHz, Memory 49152 MB), CentOS release 5.6 (Final): Linux xxx 2.6.18-238.9.1.el5 #1 SMP Tue Apr 12 18:10:13 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
Guest: Ubuntu 11.04: Linux cp-t3-u64 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Repro:
I will try to make this generic, but truth is that while this is always reproducible I do not know the real cause so is hard to indicate stepts to lead to the issue.

[0]. Please see the attached VM info file to see how it is configured.

  1. Start VM by running: VBoxHeadless -startvm [vmname] --vrdp on & (same result if I start it with VBoxManage startvm cp-t3-u64 --type vrdp)
  2. Run against the VM an [installation] process that will increase considerably the memory/cpu usage.

Actual Result:
Connectivity to the VM drops. It can no longer be accessible via VRDP or ssh, not responding to ping anymore, the install process obviously never completes so it is not just a connectivity issue, etc.

Thou the process stays up:

[cpuser@rde01 Logs]$ ps -uax | grep cp-t3-u64
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.7/FAQ
cpuser   23038 26.7  0.0 4477400 30640 ?       Sl   09:20  12:31 /usr/lib/virtualbox  /VBoxHeadless --comment cp-t3-u64 --startvm 5b50bfc5-4f43-4553-a0f0-1f38961457ac
cpuser   23159  0.0  0.0  61232   780 pts/3    S+   10:07   0:00 grep cp-t3-u64

The following is however random (or maybe time dependent):

[cpuser@rde01 Logs]$ vbm list runningvms
Oracle VM VirtualBox Command Line Management Interface Version 3.2.12
(C) 2005-2010 Oracle Corporation
All rights reserved.

''[removed the other VMs list]''
"cp-t3-u64" {5b50bfc5-4f43-4553-a0f0-1f38961457ac}

Sometimes VBoxManage still sees the VM up, some times it doesn't [even if the process is still active] (don't know if this is related to this particular issue or is a different bug thou ...).

Expected Result: For everything to run smoothly and VM to stay up and accessible.

Comments: I run top against the VM in the VRDP RDS and when it dies, CPU is usually over 60% (please see attached printScreen). I don't know if this is relevant or not but it does seem to affect the VM's lifespan (as in when I don't execute the mentioned installation the machine stays up much longer).
Also the RD connection is not refused, it is just displaying a blank screen. "Update:" I executed VBoxManage controlvm cp-t3-u64 savestate (successful) and then restarted the VM (VBoxManage startvm cp-t3-u64 --type vrdp) and the machine is indeed in the same state (still unaccesible, but RDConnection went throught and showed me the stuck top command again, ssh/ping still not working, etc) - will attach log after VM resume too.

I tried to find a simmilar problem already reported, but best I could find were people experiencing slow machines (mine is totally un-accessible) or having issues with the NIC (which I also changed to the intel desktop version and had no effect; besides my problem does not occur during the higher netload part of the installation process). So sorry if this is a duplicate of something common but I did try to avoid it.

Attachments

TopOnVMConnectionFail.jpg Download (190.2 KB) - added by sebastians 3 years ago.
top status when VM connecitivity dies
cp-t3-u64.xml Download (5.7 KB) - added by sebastians 3 years ago.
VM configuration
VBox.log Download (51.9 KB) - added by sebastians 3 years ago.
log when connectivity died
VBox_afterSavedStart.log Download (50.3 KB) - added by sebastians 3 years ago.
log after VM restarted from saved state

Change History

Changed 3 years ago by sebastians

top status when VM connecitivity dies

Changed 3 years ago by sebastians

VM configuration

Changed 3 years ago by sebastians

log when connectivity died

Changed 3 years ago by sebastians

log after VM restarted from saved state

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use