VirtualBox

Ticket #9073 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Install of Guest Additions fails while installing VBoxGuest.inf on Windows 7

Reported by: bzh_nihon Owned by:
Priority: major Component: installer
Version: VirtualBox 4.0.8 Keywords: guest additions install
Cc: Guest type: Windows
Host type: Linux

Description

Cannot install Guest Additions on Windows 7. It installs the mouse, display drivers correctly, but fails to install the guest driver. As a result the whole install rolls back.

Attachments

install_ui.log Download (2.6 KB) - added by bzh_nihon 3 years ago.
Install UI log
install.log Download (37.8 KB) - added by bzh_nihon 3 years ago.
Debug Install log
virtualbox-vga-logs.tar.bz2 Download (8.3 KB) - added by bzh_nihon 3 years ago.
new logs 20110617

Change History

Changed 3 years ago by bzh_nihon

Install UI log

Changed 3 years ago by bzh_nihon

Debug Install log

comment:1 Changed 3 years ago by misha

Could you please run guest installer with setupapi logging enabled, as described under the "Driver Installation Log" sectin  here, and post the log(s) here?

comment:2 Changed 3 years ago by misha

Please also attach the install_drivers.log log file that should be in vbox guest additions install dir.

Changed 3 years ago by bzh_nihon

new logs 20110617

comment:3 follow-ups: ↓ 4 ↓ 5 Changed 3 years ago by bzh_nihon

Ok, just attached the latest logs. Got an install.log, install_ui.log and setupapi.dev.log. There was never any MSIxxx log that was generated.

Cheers

comment:4 in reply to: ↑ 3 Changed 3 years ago by misha

Replying to bzh_nihon: thanks, what about setupapi.app.log from %windir%\inf\ and install_drivers.log from guest additions install dir, could you attach them as well?

comment:5 in reply to: ↑ 3 Changed 3 years ago by misha

Replying to bzh_nihon: as a simple attempt could you try clearing the inf cache and see if it helps? to do that remove the %windir%\inf\INFCACHE.1 file, reboot and try to run the installer again.

comment:6 Changed 3 years ago by bzh_nihon

Sorry for the late reply, I was away for a week or so.

I checked the inf folder, and there is no cache file at all. To answer your earlier question, there was no setupapi.app.log that was generated.

comment:7 Changed 3 years ago by bzh_nihon

Ok, fresh news. I just upgraded to 4.0.10 r72479, and the problem is gone. The Guest Additions installed correctly.

comment:8 Changed 3 years ago by misha

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback, I'll close this ticket then. Please reopnen if needed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use