VirtualBox

Ticket #9043 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

Guest freezes under heavy load

Reported by: yurivict Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by frank) (diff)

Ubuntu guest froze several times on MacOS host when it was heavily loaded. Load was gcc recompilation and system upgrade at the same time. What is interesting, when progress in the terminal stopped for a long time I was still able to click on the tab and it still switched and then froze completely.

I observe the same on FreeBSD host with Ubuntu and Solaris 11 guests. (I know that FreeBSD isn't officially supported but freezing behavior is consistent with MacOS host). Especially Solaris 11 guest there causes freezes with ~50% chance during gcc rebuild.

I think this is a regression since I never saw this on the earlier versions.

Change History

comment:1 Changed 3 years ago by frank

Please retry with VBox 4.0.10.

comment:2 Changed 3 years ago by matschaffer

This seems similar to what I saw today on 4.1 and 4.0. Usually during an apt-get, the guest would over-consume CPU to the point where the host became unusable. So far the only workaround I've found is to use  http://www.willnolan.com/cputhrottle/cputhrottle.html to limit the CPU usage. Even this isn't perfect as the CPU still hits 100% sometimes.

comment:3 Changed 3 years ago by matschaffer

yurivict, are you on Mac OS Lion? I seemed to start seeing this is as soon as I switched from Snow Leopard to Lion.

comment:4 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use