VirtualBox

Ticket #903 (closed defect: fixed)

Opened 6 years ago

Last modified 7 months ago

CD/DVD passthrough doesn't work

Reported by: Technologov Owned by:
Priority: major Component: DVD
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Host: Windows XP SP2 and openSUSE 10.3, 4GB of RAM, Core 2 Quad, VBox 1.5.2.

Guest: Windows XP.

CD/DVD passthrough doesn't work. That means: I cannot burn CDs or DVDs from guest. Erasing DVD+-RW's and writing Lightscribe labels don't work either.

-Technologov, 17.11.2007.

Attachments

VBox.log Download (35.5 KB) - added by evilmonkey 6 years ago.
VBox.2.log Download (31.7 KB) - added by firecat53 6 years ago.
Windows XP-2008-11-08-19-43-27.log Download (50.1 KB) - added by sierpins 5 years ago.
Mac OS X 10.5.5 host log file

Change History

comment:1 Changed 6 years ago by Technologov

My physical device is: LG HL-DT-ST DVDRAM GSA-H12L

Device caps: CD-ROM, CD-R/RW, DVD-ROM, DVD-RAM, DVD-R/RW, DVD+R/RW, and Lightscribe Technology.

Tried with Nero 6 Ultra v6.6.0.8 installed on guest.

-Technologov, 17.11.2007.

comment:2 Changed 6 years ago by klaus

Could you please attach a VBox.log file for both host OSes? It should say whether passthrough is silently disabled (if it is, there is usually a permission problem). It might also contain some error messages that indicate what problem exists with sending ATAPI commands to the drive when you try to burn something.

IIRC WinXP produces different icons/texts for the optical drive in the "My Computer" folder for drives with/without write capability, so that also provides information whether the passthrough mode is successfully enabled or not.

comment:3 Changed 6 years ago by evilmonkey

Same problem. Was either extremely slow to read from drive, or did not read. Host: Linux Mint 4 based on Ubuntu 7.10; vbox 1.5.2 (closed source) Guest: Windows XP Pro Physical Drive: Benq DVD DD DW1650 firmware BCHC

Will attach log.

Changed 6 years ago by evilmonkey

comment:4 Changed 6 years ago by firecat53

I also have this issue. Running virtualbox 1.5.6 (passthrough enabled). WinXP home guest, Ubuntu 7.10 amd64 host. Installed Infra Recorder and tried to blank a cd-rw. Had to switch to a virtual terminal and reboot the computer. The light just started blinking on the cd-drive, I could move the mouse in XP and Ubuntu, but no keyboard input other than the ctrl-alt F1 was accepted. I attached the vbox.log above, but the errors were repeats of:

00:07:37.979 PIIX3 ATA: LUN#2: CD-ROM passthrough command (0x5a) error 5 VERR_DEV_IO_ERROR

The cd drive shows up correctly named as the dvd-ram drive, but under device properties, it just shows it as a vbox-cd rom or some such. Tried uninstalling the driver in XP, but it just reinstalled the same one again.

Let me know if I can provide additional information. Thanks, Scott

Changed 6 years ago by firecat53

comment:5 Changed 6 years ago by firecat53

Hmmmmm, interesting. I just put in the cd-rw that I tried to blank, and it actually did get blanked! Apparently everything just froze up afterwards. I tried writing a blank cd-rw, but InfraRecorder gave input/output errors and said the CUE sheet couldn't be written.

Scott

comment:6 Changed 6 years ago by frank

  • Component changed from other to DVD

comment:7 Changed 6 years ago by carsses

Lightscribe Lacie porche lightscribe(firewire connect) it read but Can't print lightscribe labels. I have install virtualbox install in MacOs X Leopard (intell) and virtualized xp, ubuntu, debian lenny.

comment:8 Changed 6 years ago by frank

carsses, please attach a VBox.log file of a session after you tried to print such lables.

comment:9 Changed 5 years ago by sierpins

I have the same problem on a Mac OS 10.5.5 host with both my Ubuntu 8.04 and Windows XP SP3 guests. When I put in a blank CD, my Windows guest recognizes it as an audio CD and it will not burn. The Ubuntu guest will not burn either. I have checked off the "enable passthrough" checkbox. I am attaching a log from the host.

Changed 5 years ago by sierpins

Mac OS X 10.5.5 host log file

comment:10 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use