VirtualBox

Ticket #9003 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Mac OS host cannot pass USB storage devices to guest OSs

Reported by: CaptSaltyJack Owned by:
Priority: critical Component: USB
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

I've found a bug in Mac OS VirtualBox. I was completely unable to pass control of any USB storage devices to any type of guest (Windows, Linux) until on the Mac OS host I temporarily moved /System/Library/Extensions/IOUSBMassStorageClass.kext to the desktop, rebooted the host, then ran VBox again and attempted to use a USB device in a Linux guest.

Somehow IOUSBMassStorageClass.kext is interfering with passing USB storage devices to guest operating systems.

Change History

comment:1 Changed 3 years ago by CaptSaltyJack

No one's looked at this yet? It's critical.. USB storage devices do not work under Mac OS, at all.

comment:2 Changed 3 years ago by frank

Are you talking about SMP guests? Then this is a duplicate of #7462.

comment:3 Changed 3 years ago by CaptSaltyJack

Thanks.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use