VirtualBox

Ticket #8972 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

"VBoxManage modifyvm --name" fails to rename config file

Reported by: neuron Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Machine exists and has correct config file

$ VBoxManage showvminfo appliance.2010.q3.1.0 | grep Config\ file Config file: /dir/user/test/appliance.2010.q3.1.0.vbox

$ VBoxManage modifyvm appliance.2010.q3.1.0 --name test

... no issue there

$ VBoxManage modifyvm appliance.2010.q3.1.0 --name test VBoxManage: error: Could not find a registered machine named 'appliance.2010.q3.1.0' VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "FindMachine(Bstr(a->argv[0]).raw(), machine.asOutParam())" at line 336 of file VBoxManageModifyVM.cpp

... The configuration file is set still to the same path:

$ cat $VBOX_USER_HOME/*xml | grep MachineEntry

<MachineEntry uuid="{84e0c697-7a89-70c1-2dbb-76dd396a90e9}" src="/dir/user/test/appliance.2010.q3.1.0.vbox"/>

... But it was actually renamed:

$ ls /dir/user/test/*.vbox /dir/user/test/test.vbox

Changing the $VBOX_USER_HOME/VirtualBox.xml so that it points to test.vbox fixes things.

It might be releated, I don't have my .VirtualBox in standard path, but I'm rather using

$ echo $VBOX_USER_HOME /dir/user/.VirtualBox

Change History

comment:1 Changed 3 years ago by neuron

Sorry, duplicate of #8973: "VBoxManage modifyvm --name" fails to rename config file

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use