VirtualBox

Ticket #8963 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VirtualBox Reboots Host machine randomly

Reported by: seboch Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.8 Keywords: reboots host
Cc: Guest type: Linux
Host type: Windows

Description

VirtualBox Reboots Host Machine randomly.

The problem looks very similar to Ticket 8202  http://www.virtualbox.org/ticket/8202.

I reproduced the problem using VBox version 4.0.4, 4.0.6, 4.0.8 with the same guest on 2 different host machines.

Host 1:

  • Dell Latitude E5510
  • Processor Intel Core i5 CPU M560
  • Windows 7 Professional 32bit SP1

Host 2:

  • Dell Precision T1500.
  • Processor Intel Core i5 CPU 760
  • Windows 7 Professional 32bit SP1

Guest description:

  • Ubuntu 10.10 64 bit

I didn't reproduce the issue while running a 32 bit guest

Attachments

VBox.log Download (50.0 KB) - added by seboch 3 years ago.
Vbox log for Host1 just before crash
VBox - Second Crash.log Download (50.6 KB) - added by seboch 3 years ago.
VBox Log of second crash
Second Crash.dmp Download (213.9 KB) - added by seboch 3 years ago.
Windows Minidump for Second Crash

Change History

Changed 3 years ago by seboch

Vbox log for Host1 just before crash

Changed 3 years ago by seboch

VBox Log of second crash

Changed 3 years ago by seboch

Windows Minidump for Second Crash

comment:1 Changed 3 years ago by seboch

I activated the driver verifier on VBoxUSBMon as described in ticket #8202 I reproduced and got a BSOD and minidump.

You will find in attachment the windows minidump (Second Crash.dmp) and the VBox.log (VBox - Second Crash.log)

Is there a way to disable the VBox USB driver? would this solve the issue?

comment:2 Changed 3 years ago by frank

The USB driver can be disabled during the VirtualBox installation. You probably need to uninstall VirtualBox and reinstall it, this time without USB support. After that, make sure that there is no VBoxUSB* in the Windows drivers directory (c:\windows\system32\drivers). It would definitely help if you can confirm that without installing the USB driver your host will not crash anymore.

comment:3 follow-up: ↓ 4 Changed 3 years ago by seboch

I uninstalled and reinstalled without the USB support but VBoxUSBMon.sys is still present in the driver directory

comment:4 in reply to: ↑ 3 Changed 3 years ago by misha

Replying to seboch:

I uninstalled and reinstalled without the USB support but VBoxUSBMon.sys is still present in the driver directory

Yes, VBoxUSBMon.sys could remain, never the less if you install VBox w/o the USB support it should not be running. To ensure it is true, please start VBox and then run "sc query VBoxUSBMon" from the command line, it should say VBoxUSBMon service does not exist.

comment:5 Changed 3 years ago by misha

Also, if the issue persists w/o a USB support installed, it's worth to try to enable driver verifier for other VBox drivers, i.e. VBoxDrv.sys, VBoxNetFlt.sys & VBoxNetAdp.sys and see if it detects something.

comment:6 Changed 3 years ago by seboch

The sc query confirms that the driver is not running. I'll use the VM like this and I'll let you know how it goes.

comment:7 Changed 3 years ago by seboch

I let the VBox run the whole day and so far it seems stable when USB driver is disabled.

comment:8 follow-up: ↓ 9 Changed 3 years ago by seboch

It crashed again today w/o USB support installed. I will enable the driver verifier for other VBox drivers.

comment:9 in reply to: ↑ 8 ; follow-up: ↓ 10 Changed 3 years ago by misha

Replying to seboch: To get the source of the problem, it would be very helpful if you are able to connect your failing machine to the kernel debugger. Most likely the crash that leads to the host restart would result in a break in kernel debugger, where you will be able to create a dump of a failing system state (i.e. a minidump, a kernel memory dump or a full dump).

You can get the steps on how to setup a windows kernel debugger and do a mempry dump from it  here. Let me know if you have any problem or need any help with that.

comment:10 in reply to: ↑ 9 Changed 3 years ago by seboch

Hi,

I'm afraid I won't be able to spend more time to debug this problem now plus I don't have 1394 cables so I'll probably look at other virtualization solutions.

I'll let you know the result if I find time to setup the described environment.

comment:11 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

This could be a duplicate of #9458. Forcing the host kernel to use a non-PAE kernel might help.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use