VirtualBox

Ticket #896 (new defect)

Opened 6 years ago

Last modified 6 years ago

Error "hard disk with two children" after disk full during "discard current snapshot"

Reported by: fjp Owned by:
Priority: minor Component: VM control
Version: VirtualBox 1.5.2 Keywords: snapshot
Cc: Guest type: other
Host type: other

Description

I had a fairly long series of snapshots without noticing that I was running out of disk space. I wanted to get back to an earlier snapshot, so selected "discard current snapshot and state".

After a while I got an error that the operation failed because lack of diskspace. After freeing up some space I tried again but the discard would not start with an error message saying that a disk had two children (sorry, don't have exact message anymore).

The attached screenshot shows the situation in the disk manager.

I managed to recover by deleting one of the children from ~/.VirtualBox/VirtualBox.xml (and modifying a reference to that snapshot in the machine's XML file). After that deleting the snapshots worked again.

I'm running the Debian virtualbox-ose 1.5.2 package.

Attachments

VBox_snapshot.png Download (63.3 KB) - added by fjp 6 years ago.
Screenshot of disk manager

Change History

Changed 6 years ago by fjp

Screenshot of disk manager

comment:1 Changed 6 years ago by frank

  • Component changed from other to VM control
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use