VirtualBox

Ticket #8943 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

VM is "inaccessible"

Reported by: VolkerBause Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.0.8 Keywords: 4.0.8 inaccessible logout reboot
Cc: Guest type: Windows
Host type: Linux

Description

I am referring to the same problem as can be found here:  http://forum.virtualbox.org/viewtopic.php?f=7&t=41725&start=0#p187779

Not sure if it is the 4.0.8 Guest Editions or not. Fact is that once I close (i.e. Logout) the KDE 4.6 on OpenSUSE 11.4 x86_64 with standard updates in place, I get this problem. One fix is to close the Virtualbox Control Panel and then edit the Virtual machine .vbox file and remove the value between quotes of VersionEx under <GuestProperties>. The value assigned appears to be incorrect!? The problem will return upon next start-up of guest OS and the login out and back in to KDE or rebooting.

<GuestProperty name="/VirtualBox/GuestAdd/VersionEx" value=" " timestamp="1306076154841406000" flags=""/>

Starting Virtualbox Control Panel after having edited this with kwrite with Virtualbox Control Panel closed and having saved the file fixes the issue which tells me this is a bug. I run Windows 7 Ultimate FPP as Guest under OpenSUSE 11.4 x86_64. The problem only appears to take plays once restarting Linux or logging out of KDE. Very puzzling indeed.

I will try older versions of Virtualbox 4.0.6 etc. to see if I can replicate the problem. Fact is that I am not the only person experiencing this problem and the other person reported this under Ubuntu and not OpenSUSE host. He also uses Windows 7 64 bit as guest!

Change History

comment:1 Changed 3 years ago by VolkerBause

Downgraded Virtualbox to 4.0.6 under OpenSUSE 11.4 x86_64 Host. Removed existing .vbox files just to be sure. Recreated Virtual machine and attached existing .vdi file. Installed Guest Editions for 4.0.6 in Windows 7 safe mode. Rebooted. This FIXED this bug!

Upgraded Virtualbox 4.0.6 to 4.0.8 under Linux without upgrading Guest Editions. Everything still OK after reboot of Linux host. This proves to me that the problem is most probably with 4.0.8 guest editions and the value written into VersionEx key. Can't see any difference in performance so I will leave Host at 4.0.8. and Guest Editionsa at 4.0.6.

Their is a bug in Virtualbox 4.0.8 which is evident upon host reboot and also during logout out of KDE4.6. Not sure why but this machine will be delivered to the client tomorrow and I don't have anymore time to help trouble shoot this problem on this specific machine.

I do have a secondary machine running even older version of Virtualbox with same type of setup. If you do find a bug or solution, I would be willing to assist trouble shooting on this but I can only do so as I get the time. Please try establishing and fixing this problem on your own if possible as I won't guarantee that I will get the time.

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Oh, you are definitely correct with your investigation. Sorry that I didn't found this earlier. Actually a duplicate of #8948 and fixed some time ago.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use