VirtualBox

Ticket #8932 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VM settings not always saved when VMM closed

Reported by: marshals Owned by:
Priority: minor Component: VMM
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: other
Host type: Windows

Description

I noticed this when changing a VM (that I had just taken a snapshot of) to have more memory for "next time", ie, I made the change but exited the VMM without restarting the VM. When I next started the VMM, the VM memory change had been lost. It seems the .vbox file was not written.

To reproduce:

  • start VMM
  • select a VM that is identical to its last snapshot [I think this is required]
  • change memory setting of the VM [verify VMM reflects change for VM]
  • close VMM
  • start VMM

and I see in the VMM that the change to VM has been lost.

If I start the VM before closing the VMM, then the change is not lost.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by frank

Cannot reproduce. Are you really using VBox 4.0.8? And does the VM have snapshots? If so, are all of them online snapshots or offline snapshots?

comment:2 in reply to: ↑ 1 Changed 3 years ago by marshals

Replying to frank:

Cannot reproduce. Are you really using VBox 4.0.8? And does the VM have snapshots? If so, are all of them online snapshots or offline snapshots?

Yes, I'm using 4.0.8r71778, installed yesterday.

Yes, the VMs have snapshots and all are off-line. As I stated above, I think to see this bug the VM must be identical to its last snapshot.

I reproduced the problem repeatedly with 2 VMs as I was writing the op, one with 2 snapshots, one with 3 snapshots.

I've been trying to reproduce again and it's getting thoroughly bizarre. I changed a VM from 1.5G to 2G. When I restarted the VMM the VM did indeed have 2G. However, I restarted the VMM again and the VM is back to 1.5G. Gah! Playing around, sometimes it takes a single restart of the VMM, sometimes more than one. I'm a bit baffled. VB is installed on a different drive from the VM data, though on the same disk. I'll see if rebooting the host (Win7-64b) makes any difference...

comment:3 Changed 3 years ago by marshals

... no it does not.

comment:4 Changed 3 years ago by marshals

See also  http://www.virtualbox.org/ticket/8933, though it's worth noting I could still reproduce this problem following a host reboot (which that VB crash pre-dates).

comment:5 Changed 3 years ago by marshals

I can confirm this is still the case with 4.0.10.

comment:6 follow-up: ↓ 7 Changed 3 years ago by frank

Should be finally fixed in VBox 4.1.4, please confirm.

comment:7 in reply to: ↑ 6 Changed 3 years ago by marshals

Replying to frank:

Should be finally fixed in VBox 4.1.4, please confirm.

Seems to be OK now, thanks.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use